Bug 18983 - koha-create does not default to --create-db
Summary: koha-create does not default to --create-db
Status: NEW
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: 17.05
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-25 20:26 UTC by C.J.S. Hayward
Modified: 2018-07-03 05:30 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description C.J.S. Hayward 2017-07-25 20:26:00 UTC
I reported in an email on the list that, after clearing away previous and possibly conflicting material, I found a .in file in /etc but didn't see how to make an appropriate koha-conf.xml.

The reply I received was that there was apparently an issue that "koha-create library" should, by default, behave as if "koha-create --create-db library" had been entered. However, it did not.

When I ran "koha-create --create-db library" it worked further and populated /etc/koha/sites/library with several configuration files.

N.B. I got further, but I do not yet have a real site (attempting to configure the webinstaller gets redirected to a maintenance mode page at /cgi-bin/koha/maintenance.pl); however, that may be a separate issue.
Comment 1 David Cook 2018-07-03 05:30:17 UTC
I had this same issue... I had to specify "koha-create --create-db library" rather than "koha-create library" as I was getting the following error message with the latter command:

'failed to load external entity "/etc/koha/sites/library/koha-conf.xml"'