Bug 19018 - Can we make XSLT_Handler a little bit less verbose ?
Summary: Can we make XSLT_Handler a little bit less verbose ?
Status: RESOLVED DUPLICATE of bug 20272
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 17807
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 13:37 UTC by Marcel de Rooy
Modified: 2018-02-22 13:49 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2017-08-01 13:37:29 UTC
As reported on bug 17807, XSLT_Handler reports that a XSLT file is not found for each record it wants to process (running oai.pl).

Additionally, we also have:
Can't locate object method "nodeType" via package "<?xml version="1.0" encoding="UTF-8"?>
[ And a complete MARC record dump. ]
" (perhaps you forgot to load "<?xml version="1.0" encoding="UTF-8"?>
[ Same MARC record dump again ]
"?) at /usr/share/perl5/HTTP/OAI/Encapsulation.pm line 68.
Comment 1 Marcel de Rooy 2018-02-22 13:49:22 UTC
(In reply to Marcel de Rooy from comment #0)
> As reported on bug 17807, XSLT_Handler reports that a XSLT file is not found
> for each record it wants to process (running oai.pl).
> 
> Additionally, we also have:
> Can't locate object method "nodeType" via package "<?xml version="1.0"
> encoding="UTF-8"?>
> [ And a complete MARC record dump. ]
> " (perhaps you forgot to load "<?xml version="1.0" encoding="UTF-8"?>
> [ Same MARC record dump again ]
> "?) at /usr/share/perl5/HTTP/OAI/Encapsulation.pm line 68.

Will make XSLT_Handler print less warnings on report 20272.
If anyone else want to address the OAI warn, please reopen/rename this one.

*** This bug has been marked as a duplicate of bug 20272 ***