Bug 19020 - No "hold available" notification when an item on hold is transferred
Summary: No "hold available" notification when an item on hold is transferred
Status: RESOLVED DUPLICATE of bug 19116
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P4 normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-01 15:43 UTC by Sophie MEYNIEUX
Modified: 2017-09-26 07:14 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sophie MEYNIEUX 2017-08-01 15:43:55 UTC
When an item is returned, if it comes from a transfer for a reserve, reserve status is changed to 'W', but not notification is sent

The function C4::Circulation::AddReturn should use ModReserveAffect() instead of C4::Reserves::ModReserveStatus($item->{'itemnumber'}, 'W') in the part dedicated to transfer
Comment 1 Katrin Fischer 2017-08-15 16:24:09 UTC
Could this be related to 19116?
Comment 2 Julian Maurice 2017-09-26 07:14:01 UTC
(In reply to Katrin Fischer from comment #1)
> Could this be related to 19116?

I'm not sure how bug 19116 fix this, but it does :)

Closing this one.

*** This bug has been marked as a duplicate of bug 19116 ***