Bug 19172 - Undefined subroutine &C4::Members::Attributes::SearchIdMatchingAttribute when searching patrons
Summary: Undefined subroutine &C4::Members::Attributes::SearchIdMatchingAttribute when...
Status: RESOLVED DUPLICATE of bug 19418
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-24 12:22 UTC by David Gustafsson
Modified: 2017-10-06 13:03 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Add missing use statement for C4::Members::Attributes (732 bytes, patch)
2017-08-24 12:41 UTC, David Gustafsson
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description David Gustafsson 2017-08-24 12:22:30 UTC
When "ExtendedPatronAttributes" is enabled the following error occurs when searching patrons:

"Undefined subroutine &C4::Members::Attributes::SearchIdMatchingAttribute called at ../C4/Utils/DataTables/Members.pm line 124"

I assume this is because a missing "use C4/Utils/DataTables/Members.pm;". I have fixed and tested this in my local instance and will supply a patch shortly.
Comment 1 David Gustafsson 2017-08-24 12:37:54 UTC
Oops, "use C4::Members::Attributes;" I meant.
Comment 2 David Gustafsson 2017-08-24 12:41:05 UTC
Created attachment 66413 [details] [review]
Add missing use statement for C4::Members::Attributes
Comment 3 Katrin Fischer 2017-08-26 21:58:15 UTC
I've tried different searches for patrons with patron attributes active and added to the patron record on master and didn't manage to trigger the error.

Which version did you test with? 
Can you add a step by step test plan on how to trigger the error please?
Comment 4 Jonathan Druart 2017-09-27 17:09:06 UTC
Which OS? What is your perl version?
Comment 5 Jonathan Druart 2017-10-06 13:03:54 UTC

*** This bug has been marked as a duplicate of bug 19418 ***