Bug 19205 - Pay selected fine generates 500 error
Summary: Pay selected fine generates 500 error
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 15908
Blocks: 19208
  Show dependency treegraph
 
Reported: 2017-08-30 13:34 UTC by Andreas Hedström Mace
Modified: 2017-09-15 22:47 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19205 - Pay selected fine generates 500 error (1.11 KB, patch)
2017-08-30 13:39 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 19205 - Pay selected fine generates 500 error (1.27 KB, patch)
2017-08-30 14:00 UTC, Andreas Hedström Mace
Details | Diff | Splinter Review
Bug 19205 - Pay selected fine generates 500 error (1.34 KB, patch)
2017-08-30 14:46 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hedström Mace 2017-08-30 13:34:56 UTC
Using the pay selected option from the borrowers account, to pay for one specific fine among other gives a 500 error, despite the payment going through.

To reproduce:
Add two fines using the Create manual invoice function.
Select one fine and "pay selected".
Pay a part of the amount.
Comment 1 Kyle M Hall 2017-08-30 13:39:05 UTC
Created attachment 66612 [details] [review]
Bug 19205 - Pay selected fine generates 500 error

Using the pay selected option from the borrowers account, to pay for one specific fine among other gives a 500 error, despite the payment going through.

Test Plan:
1) Add two fines using the Create manual invoice function.
2) Select one fine and "pay selected".
3) Pay a part of the amount.
4) Note error
5) Apply this patch
6) Repeat steps 1-3
7) No error!
Comment 2 Andreas Hedström Mace 2017-08-30 14:00:49 UTC
Created attachment 66614 [details] [review]
Bug 19205 - Pay selected fine generates 500 error

Using the pay selected option from the borrowers account, to pay for one specific fine among other gives a 500 error, despite the payment going through.

Test Plan:
1) Add two fines using the Create manual invoice function.
2) Select one fine and "pay selected".
3) Pay a part of the amount.
4) Note error
5) Apply this patch
6) Repeat steps 1-3
7) No error!

Signed-off-by: Andreas Hedström Mace <andreas.hedstrom.mace@sub.su.se>
Comment 3 Jonathan Druart 2017-08-30 14:46:34 UTC
Created attachment 66619 [details] [review]
Bug 19205 - Pay selected fine generates 500 error

Using the pay selected option from the borrowers account, to pay for one specific fine among other gives a 500 error, despite the payment going through.

Test Plan:
1) Add two fines using the Create manual invoice function.
2) Select one fine and "pay selected".
3) Pay a part of the amount.
4) Note error
5) Apply this patch
6) Repeat steps 1-3
7) No error!

Signed-off-by: Andreas Hedström Mace <andreas.hedstrom.mace@sub.su.se>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 4 Jonathan Druart 2017-08-30 20:02:50 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 5 Fridolin SOMERS 2017-09-12 14:22:55 UTC
Pushed to 17.05.x, will be in 17.05.04.
Comment 6 Katrin Fischer 2017-09-15 22:47:56 UTC
I can't reproduce the error in 16.11.x and bug 15908 this depends on is not in 16.11.x.