Bug 19207 (Osimandias) - Don't export fields
Summary: Don't export fields
Status: RESOLVED WORKSFORME
Alias: Osimandias
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: 3.22
Hardware: PC Linux
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-30 13:58 UTC by Marcos Benincasa
Modified: 2021-04-03 15:18 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
srceenshot GUI option (12.70 KB, image/png)
2017-08-30 13:58 UTC, Marcos Benincasa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos Benincasa 2017-08-30 13:58:59 UTC
Created attachment 66613 [details]
srceenshot GUI option

In the GUI option "Don't export fields" (of export.pl) is not expressed correctly. It does not exclude the field of the exported records, What it does, is to exclude the records that contain that field.
Comment 1 Katrin Fischer 2017-09-05 20:34:33 UTC
Please see also 19207 for a discussion about changes to the form!
Comment 2 Katrin Fischer 2017-09-05 20:34:49 UTC
Sorry, bug 18201!
Comment 3 Jonathan Druart 2017-09-27 17:07:25 UTC
(In reply to Marcos Benincasa from comment #0)
> It does not exclude the field of the exported records, What it does, is to exclude the records that contain that field.

Are you sure? I would like you to confirm this behaviour, because what you expect is the expected behaviour.
Comment 4 Katrin Fischer 2021-04-03 15:18:28 UTC
I belive the "Don't export fields" option to work correctly removing only the fields, not the records from the export. I just verified this on master with a couple records and removing the 245 field.