Bug 19334 - circulation history doesn't set biblionumber so left navigation is broken
Summary: circulation history doesn't set biblionumber so left navigation is broken
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Dobrica Pavlinusic
QA Contact: Julian Maurice
URL:
Whiteboard:
Keywords:
Depends on: 18260
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-18 17:15 UTC by Dobrica Pavlinusic
Modified: 2017-10-17 08:06 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19334 - circulation history doesn't set biblionumber so left navigation is broken (1.06 KB, patch)
2017-09-18 17:20 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
Bug 19334 - circulation history doesn't set biblionumber so left navigation is broken (1.12 KB, patch)
2017-09-22 09:06 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 19334 - circulation history doesn't set biblionumber so left navigation is broken (1.18 KB, patch)
2017-09-29 11:59 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Dobrica Pavlinusic 2017-09-18 17:15:38 UTC

    
Comment 1 Dobrica Pavlinusic 2017-09-18 17:20:48 UTC
Created attachment 67188 [details] [review]
Bug 19334 - circulation history doesn't set biblionumber so left navigation is broken

Navigation on the left (Normal, MARC, etc...) needs biblionumber in
template variables to work.

Test:
1. go to checkout history for any biblio
2. verify that normal, MARC, etc links on the left no longer work
   due to missing biblionumber in URL
3. apply patch and test it again
Comment 2 Jonathan Druart 2017-09-18 19:01:20 UTC
Caused by bug 18260.
Comment 3 Lee Jamison 2017-09-18 20:56:57 UTC
Patch does not address the bug. The problem still exists after the patch is applied.
Comment 4 Jonathan Druart 2017-09-19 11:47:29 UTC
(In reply to Lee Jamison from comment #3)
> Patch does not address the bug. The problem still exists after the patch is
> applied.

It works for me, could you detail what does not work?
Comment 5 Josef Moravec 2017-09-22 09:06:03 UTC
Created attachment 67312 [details] [review]
Bug 19334 - circulation history doesn't set biblionumber so left navigation is broken

Navigation on the left (Normal, MARC, etc...) needs biblionumber in
template variables to work.

Test:
1. go to checkout history for any biblio
2. verify that normal, MARC, etc links on the left no longer work
   due to missing biblionumber in URL
3. apply patch and test it again

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 6 Julian Maurice 2017-09-29 11:59:25 UTC
Created attachment 67439 [details] [review]
Bug 19334 - circulation history doesn't set biblionumber so left navigation is broken

Navigation on the left (Normal, MARC, etc...) needs biblionumber in
template variables to work.

Test:
1. go to checkout history for any biblio
2. verify that normal, MARC, etc links on the left no longer work
   due to missing biblionumber in URL
3. apply patch and test it again

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Comment 7 Jonathan Druart 2017-09-29 15:49:01 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 8 Fridolin SOMERS 2017-10-17 08:06:20 UTC
Depends on Bug 18260 that is not in 17.05.x