Bug 19357 - Error when submitting biblionumbers to batch record modification
Summary: Error when submitting biblionumbers to batch record modification
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Julian Maurice
URL: /cgi-bin/koha/tools/batch_record_modi...
Whiteboard:
Keywords:
Depends on: 18260
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-21 14:04 UTC by Owen Leonard
Modified: 2017-10-17 08:08 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19357: (bug 18260 follow-up) Remove non-relevant attributes (1.92 KB, patch)
2017-09-21 14:13 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 19357: (bug 18260 follow-up) Remove non-relevant attributes (1.97 KB, patch)
2017-09-21 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19357: (bug 18260 follow-up) Remove non-relevant attributes (2.03 KB, patch)
2017-09-29 11:57 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2017-09-21 14:04:02 UTC
Submitting a batch of biblionumbers to batch record modification results in an error:

Template process failed: undef error - The method itemnumbers is not covered by tests! at /home/vagrant/kohaclone/C4/Templates.pm line 121.
Comment 1 Jonathan Druart 2017-09-21 14:09:47 UTC
Caused by
  commit c73e269a13f64fe016dc90941280c9d2e9cfb02c
    Bug 18260: Koha::Biblio - Remove GetBiblio
Comment 2 Jonathan Druart 2017-09-21 14:13:47 UTC
Created attachment 67279 [details] [review]
Bug 19357: (bug 18260 follow-up) Remove non-relevant attributes

When created, batch_record_modification.tt has been based on
batch_delete_records.tt
These attributes are not used in the template and not set in the pl
script.
Since bug 18260, biblio is a Koha::Biblio and calling a non-existent
method will raise an error.

This patch get rid of the following error:
batch_record_modification.pl: Template process failed: undef error - The
method itemnumbers is not covered by tests!

Test plan:
Modify bibliographic records with the "Batch record modification" tool.
Comment 3 Jonathan Druart 2017-09-21 14:14:58 UTC
Note that this patch can be backported, but I prefer to keep the dependency with bug 18260.
Comment 4 Owen Leonard 2017-09-21 14:24:17 UTC
Created attachment 67280 [details] [review]
[SIGNED-OFF] Bug 19357: (bug 18260 follow-up) Remove non-relevant attributes

When created, batch_record_modification.tt has been based on
batch_delete_records.tt
These attributes are not used in the template and not set in the pl
script.
Since bug 18260, biblio is a Koha::Biblio and calling a non-existent
method will raise an error.

This patch get rid of the following error:
batch_record_modification.pl: Template process failed: undef error - The
method itemnumbers is not covered by tests!

Test plan:
Modify bibliographic records with the "Batch record modification" tool.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Julian Maurice 2017-09-29 11:57:04 UTC
Created attachment 67438 [details] [review]
Bug 19357: (bug 18260 follow-up) Remove non-relevant attributes

When created, batch_record_modification.tt has been based on
batch_delete_records.tt
These attributes are not used in the template and not set in the pl
script.
Since bug 18260, biblio is a Koha::Biblio and calling a non-existent
method will raise an error.

This patch get rid of the following error:
batch_record_modification.pl: Template process failed: undef error - The
method itemnumbers is not covered by tests!

Test plan:
Modify bibliographic records with the "Batch record modification" tool.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Comment 6 Jonathan Druart 2017-09-29 15:49:19 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 7 Fridolin SOMERS 2017-10-17 08:08:43 UTC
Depends on Bug 18260 that is not in 17.05.x