Bug 19383 - Print hold slips without confirmation
Summary: Print hold slips without confirmation
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Kyle M Hall
QA Contact: Katrin Fischer
URL:
Whiteboard:
Keywords: release-notes-needed
Depends on:
Blocks:
 
Reported: 2017-09-28 13:14 UTC by Kyle M Hall
Modified: 2018-11-10 10:12 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 19383: Add ability to print hold receipts automatically (10.85 KB, patch)
2018-05-03 12:26 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 19383: Add ability to print hold receipts automatically (10.95 KB, patch)
2018-05-03 15:13 UTC, Séverine Queune
Details | Diff | Splinter Review
Bug 19383: Add ability to print hold receipts automatically (10.95 KB, patch)
2018-07-09 11:12 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 19383: Add ability to print hold receipts automatically (11.05 KB, patch)
2018-08-22 18:51 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19383: (QA follow-up) Remove unused name variable (1.38 KB, patch)
2018-08-22 18:51 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2017-09-28 13:14:34 UTC
Some libraries don't wish to require librarians to confirm each hold during checkin. Instead they would like to only be alerted that a hold was filled. To implement this we should:
1) Implement new system preference to automatically confirm holds
2) Implement new system preference to automatically print confirmed hold receipts
Comment 1 Kyle M Hall 2018-05-03 12:26:48 UTC
Created attachment 75009 [details] [review]
Bug 19383: Add ability to print hold receipts automatically

Some libraries don't wish to require librarians to confirm each hold during checkin. Instead they would like to only be alerted that a hold was filled.

Test Plan:
1) Apply this patch
2) Run updatedatabase.pl
3) Enable the new syspref HoldsAutoFill
4) Check in an item that should be trapped for a hold
5) Note that instead of the modal asking if the hold should be filled,
   instead you get a message box showing the hold was filled, along
   with a button to print the hold slip.
6) Enable the new syspref HoldsAutoFillPrintSlip
7) Repeat step 4
8) Note the same behavior, but this time the print dialog displays
   automatically
Comment 2 Séverine Queune 2018-05-03 15:13:48 UTC
Created attachment 75015 [details] [review]
Bug 19383: Add ability to print hold receipts automatically

Some libraries don't wish to require librarians to confirm each hold during checkin. Instead they would like to only be alerted that a hold was filled.

Test Plan:
1) Apply this patch
2) Run updatedatabase.pl
3) Enable the new syspref HoldsAutoFill
4) Check in an item that should be trapped for a hold
5) Note that instead of the modal asking if the hold should be filled,
   instead you get a message box showing the hold was filled, along
   with a button to print the hold slip.
6) Enable the new syspref HoldsAutoFillPrintSlip
7) Repeat step 4
8) Note the same behavior, but this time the print dialog displays
   automatically

Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>
Comment 3 Katrin Fischer 2018-07-08 13:50:29 UTC
Just noticed, there is a typo in the author line:
Kyle M Hall <kyle@bywatetsolutions.com>
watet instead of water
Comment 4 Kyle M Hall 2018-07-09 11:12:12 UTC
(In reply to Katrin Fischer from comment #3)
> Just noticed, there is a typo in the author line:
> Kyle M Hall <kyle@bywatetsolutions.com>
> watet instead of water

Thanks for the catch!
Comment 5 Kyle M Hall 2018-07-09 11:12:51 UTC
Created attachment 76787 [details] [review]
Bug 19383: Add ability to print hold receipts automatically
Comment 6 Katrin Fischer 2018-08-21 22:23:20 UTC
Comment on attachment 76787 [details] [review]
Bug 19383: Add ability to print hold receipts automatically

Review of attachment 76787 [details] [review]:
-----------------------------------------------------------------

Hi Kyle, can you take a quick look? Will continue testing.

::: circ/returns.pl
@@ +423,5 @@
> +        ModReserveAffect( $reserve->{itemnumber}, $reserve->{borrowernumber}, $diffBranchSend, $reserve->{reserve_id} );
> +        my ( $messages, $nextreservinfo ) = GetOtherReserves($reserve->{itemnumber});
> +
> +        my $patron = Koha::Patrons->find( $nextreservinfo );
> +        my $name   = $patron ? $patron->surname . ", " . $patron->title . " " . $patron->firstname : '';

It looks like this line is not needed anymore?
Comment 7 Katrin Fischer 2018-08-22 18:51:29 UTC
Created attachment 78087 [details] [review]
Bug 19383: Add ability to print hold receipts automatically

Some libraries don't wish to require librarians to confirm each hold during checkin. Instead they would like to only be alerted that a hold was filled.

Test Plan:
1) Apply this patch
2) Run updatedatabase.pl
3) Enable the new syspref HoldsAutoFill
4) Check in an item that should be trapped for a hold
5) Note that instead of the modal asking if the hold should be filled,
   instead you get a message box showing the hold was filled, along
   with a button to print the hold slip.
6) Enable the new syspref HoldsAutoFillPrintSlip
7) Repeat step 4
8) Note the same behavior, but this time the print dialog displays
   automatically

Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Katrin Fischer 2018-08-22 18:51:34 UTC
Created attachment 78088 [details] [review]
Bug 19383: (QA follow-up) Remove unused name variable
Comment 9 Nick Clemens 2018-08-31 13:00:19 UTC
Awesome work all!

Pushed to master for 18.11
Comment 10 Katrin Fischer 2018-09-01 07:58:58 UTC
For the release notes it might be nice to rephrase it the bug title a bit. The word automatic made me think of the printer working in the background without needing interaction, but it's not quite what happens here. It's just that it takes away the other confusing options and bringing up the print screen immediately. Fast print hold slips? Speed up hold print process?
Comment 11 Martin Renvoize 2018-09-05 11:28:11 UTC
Enhancement, will not be backported to 18.05.x series.
Comment 12 Katrin Fischer 2018-09-28 15:15:25 UTC
Updated bug title after discussion with Nick.