Bug 19390 - OPAC view link in staff results should open in a new tab
Summary: OPAC view link in staff results should open in a new tab
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Katrin Fischer
QA Contact: Martin Renvoize
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-29 15:58 UTC by Katrin Fischer
Modified: 2018-09-21 12:38 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19390: Make jQuery selector more specific, so OPAC view link can open in new tab (2.12 KB, patch)
2018-08-10 17:47 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19390: Make jQuery selector more specific, so OPAC view link can open in new tab (2.21 KB, patch)
2018-08-10 19:37 UTC, Maryse Simard
Details | Diff | Splinter Review
Bug 19390: Make jQuery selector more specific, so OPAC view link can open in new tab (2.28 KB, patch)
2018-08-13 09:08 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2017-09-29 15:58:32 UTC
The OPAC view link on the detail page always opens in a new tab, but the newer link in the staf result list does not. 

All OPAC view links should open in a new tab.
Comment 1 Katrin Fischer 2018-08-10 17:47:53 UTC
Created attachment 77706 [details] [review]
Bug 19390: Make jQuery selector more specific, so OPAC view link can open in new tab

The OPAC view link in the staff result list already had a target="_blank",
but it didn't work, because of the JavaScript for the result list browser
in staff.

The JavaSript code was looking for the links to the detail page in staff
and this also selected the link to the detail page in OPAC. By changing
detail.pl to \detail.pl opac-detail.pl will no longer be selected.

To test:
- Search in the staff interface
- Click "OPAC view" links in staff result lists
- Click "OPAC view' links in detai page
- Verify both now open in a new tab
- Click other links and test that navigation (previous, next,
  return to results) works as expected
- Inside the staff client, you should see something like
  searchid=scs_1533922927978 added to the URLs
Comment 2 Maryse Simard 2018-08-10 19:37:07 UTC
Created attachment 77713 [details] [review]
Bug 19390: Make jQuery selector more specific, so OPAC view link can open in new tab

The OPAC view link in the staff result list already had a target="_blank",
but it didn't work, because of the JavaScript for the result list browser
in staff.

The JavaSript code was looking for the links to the detail page in staff
and this also selected the link to the detail page in OPAC. By changing
detail.pl to \detail.pl opac-detail.pl will no longer be selected.

To test:
- Search in the staff interface
- Click "OPAC view" links in staff result lists
- Click "OPAC view' links in detai page
- Verify both now open in a new tab
- Click other links and test that navigation (previous, next,
  return to results) works as expected
- Inside the staff client, you should see something like
  searchid=scs_1533922927978 added to the URLs

Signed-off-by: Maryse Simard <maryse.simard@inlibro.com>
Followed the test plan and it works.
Comment 3 Martin Renvoize 2018-08-13 09:08:29 UTC
Created attachment 77738 [details] [review]
Bug 19390: Make jQuery selector more specific, so OPAC view link can open in new tab

The OPAC view link in the staff result list already had a target="_blank",
but it didn't work, because of the JavaScript for the result list browser
in staff.

The JavaSript code was looking for the links to the detail page in staff
and this also selected the link to the detail page in OPAC. By changing
detail.pl to \detail.pl opac-detail.pl will no longer be selected.

To test:
- Search in the staff interface
- Click "OPAC view" links in staff result lists
- Click "OPAC view' links in detai page
- Verify both now open in a new tab
- Click other links and test that navigation (previous, next,
  return to results) works as expected
- Inside the staff client, you should see something like
  searchid=scs_1533922927978 added to the URLs

Signed-off-by: Maryse Simard <maryse.simard@inlibro.com>
Followed the test plan and it works.
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 4 Martin Renvoize 2018-08-13 09:08:54 UTC
Works as expected, no regressions found.

Passing QA
Comment 5 Nick Clemens 2018-08-14 12:54:07 UTC
Awesome work all!

Pushed to master for 18.11
Comment 6 Martin Renvoize 2018-08-16 09:55:39 UTC
Pushed to 18.05.x for 18.05.03
Comment 7 Fridolin SOMERS 2018-09-21 12:38:39 UTC
Pushed to 17.11.x for 17.11.10