Bug 19583 - Report updater triggers on auth_header.marcxml
Summary: Report updater triggers on auth_header.marcxml
Status: RESOLVED DUPLICATE of bug 19638
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: 17.05
Hardware: All All
: P5 - low minor (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 17196
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-06 22:45 UTC by Barton Chittenden
Modified: 2018-05-21 16:10 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barton Chittenden 2017-11-06 22:45:33 UTC
In Home › Reports › Guided reports wizard › Saved reports,

Any reports that use auth_header.marcxml will display

"This report seems obsolete, it uses biblioitems.marcxml field" with an "Update SQL" button.

auth_header.marcxml still exists in the schema however.

This is bound to be confusing to users.

--Barton
Comment 1 Fridolin SOMERS 2018-05-21 07:27:13 UTC
Indeed, its not relevant.
I think detecting correct reports is hard because column marcxml may be alone.

Is there a way to manually cancel this message ?
Comment 2 Fridolin SOMERS 2018-05-21 08:23:49 UTC
Oups in GIT last commit message of Bug 19582 has the wrong bug id : Bug 19583

http://git.koha-community.org/gitweb/?p=koha.git;a=commit;h=f60bff7aa0e3ca932f5572b7837d912b8681ca2a

You may recreate this bug to have a new number.
Comment 3 Katrin Fischer 2018-05-21 10:14:03 UTC
I think there is not, would be nice to be able to remove the warning.
Comment 4 Jonathan Druart 2018-05-21 13:05:30 UTC
This should be fixed by bug 19638.

*** This bug has been marked as a duplicate of bug 19638 ***
Comment 5 Fridolin SOMERS 2018-05-21 16:10:07 UTC
(In reply to Jonathan Druart from comment #4)
> This should be fixed by bug 19638.
> 
> *** This bug has been marked as a duplicate of bug 19638 ***

Ahhh super, I had forgotten this one ;)