Bug 19678 - Clicking Cancel when adding New Course to course reserves shows message Invalid Course!
Summary: Clicking Cancel when adding New Course to course reserves shows message Inval...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Course reserves (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Claire Gravely
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 19229
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-22 13:32 UTC by Claire Gravely
Modified: 2018-06-04 20:15 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course! (1.61 KB, patch)
2017-11-22 13:56 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course! (1.83 KB, patch)
2017-11-22 14:34 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course! (1.85 KB, patch)
2017-11-22 14:51 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course! (1.90 KB, patch)
2017-11-22 14:59 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course! (1.98 KB, patch)
2017-12-19 15:57 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Claire Gravely 2017-11-22 13:32:15 UTC
Clicking on the cancel link when adding a new course to course reserves displays the message 'Invalid Course!'. It would be better if it redirected back to the main Course Reserves page.

To reproduce: 
Go to Course Reserves
Click '+ New Course'
Cancel the process
You are shown 'Invalid Course!'
Comment 1 Claire Gravely 2017-11-22 13:56:14 UTC Comment hidden (obsolete)
Comment 2 Claire Gravely 2017-11-22 14:34:55 UTC
Created attachment 69278 [details] [review]
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course!

Clicking on the cancel link when adding a new course to course reserves
displays the message 'Invalid Course!'. It would be better if it
redirected back to the main Course Reserves page.

This patch redirects the user back to the main course reserves page.

To Test:

1. Go to Course Reserves

2. Click '+ New Course'

3. Cancel the process

4. You are shown 'Invalid Course!'

5. Apply patch and repeat steps 1-3

6. You are redirected back to the main course reserves page
Comment 3 Claire Gravely 2017-11-22 14:51:06 UTC
Created attachment 69280 [details] [review]
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course!

Clicking on the cancel link when adding a new course to course reserves
displays the message 'Invalid Course!'. It would be better if it
redirected back to the main Course Reserves page.

This patch redirects the user back to the main course reserves page.

To Test:

1. Go to Course Reserves

2. Click '+ New Course'

3. Cancel the process

4. You are shown 'Invalid Course!'

5. Apply patch and repeat steps 1-3

6. You are redirected back to the main course reserves page
Comment 4 Owen Leonard 2017-11-22 14:59:31 UTC
Created attachment 69281 [details] [review]
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course!

Clicking on the cancel link when adding a new course to course reserves
displays the message 'Invalid Course!'. It would be better if it
redirected back to the main Course Reserves page.

This patch redirects the user back to the main course reserves page.

To Test:

1. Go to Course Reserves

2. Click '+ New Course'

3. Cancel the process

4. You are shown 'Invalid Course!'

5. Apply patch and repeat steps 1-3

6. You are redirected back to the main course reserves page

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Jonathan Druart 2017-12-19 15:57:01 UTC
Caused by commit f55af2fc078a7d6a05238232bc276e6924307179
Bug 19229: Return to course when cancelling out of edit form
Comment 6 Jonathan Druart 2017-12-19 15:57:41 UTC
Created attachment 69916 [details] [review]
Bug 19678: Clicking Cancel when adding New Course to course reserves shows message Invalid Course!

Clicking on the cancel link when adding a new course to course reserves
displays the message 'Invalid Course!'. It would be better if it
redirected back to the main Course Reserves page.

This patch redirects the user back to the main course reserves page.

To Test:

1. Go to Course Reserves

2. Click '+ New Course'

3. Cancel the process

4. You are shown 'Invalid Course!'

5. Apply patch and repeat steps 1-3

6. You are redirected back to the main course reserves page

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 7 Jonathan Druart 2017-12-20 16:46:29 UTC
Pushed to master for 18.05, thanks to everybody involved!