Bug 19798 - Returns.pl doesn't define itemnumber for transfer-slip.
Summary: Returns.pl doesn't define itemnumber for transfer-slip.
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All Linux
: P5 - low critical (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 18276
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-12 10:18 UTC by Björn Nylén
Modified: 2018-01-22 10:53 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19798: Fix print transfer slip (1.01 KB, patch)
2017-12-19 18:54 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 19798: Fix print transfer slip (1.19 KB, patch)
2017-12-27 11:02 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 19798: Fix print transfer slip (1.24 KB, patch)
2017-12-27 21:14 UTC, Jon Knight
Details | Diff | Splinter Review
Bug 19798: Fix print transfer slip (1.30 KB, patch)
2017-12-29 07:14 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Nylén 2017-12-12 10:18:52 UTC
Marking master as version as 17.11 isn't available to select.

It seems the itemnumber isn't set in the link/button that prints transfer-slips.

To reproduce:
1. Check in available/not on hold item at a non owning library.
2. Press transfer-button.
3. Resulting slips says "Item not found".

"Inspect element" in browser for the button indicates that itemnumber is not set: "transfer-slip.pl?transferitem=&branchcode=CPL&op=slip"
Comment 1 Jonathan Druart 2017-12-19 18:53:26 UTC
This bug may have been caused by
  commit 6eade474ed3a84a5ba372a26ac27bf9fb4bd2299
    Bug 18276: Remove GetBiblioFromItemNumber - Easy ones
Comment 2 Jonathan Druart 2017-12-19 18:54:39 UTC
Created attachment 69925 [details] [review]
Bug 19798: Fix print transfer slip

... and maybe other bugs as well
What happens here is that $itemnumber is no longer set when barcode is
passed.

Test plan:
1. Check in available/not on hold item at a non owning library.
2. Click print slip
3. Item's info must be displayed on the slip
Comment 3 Jonathan Druart 2017-12-19 18:54:54 UTC
Related with bug 19840
Comment 4 sandboxes@biblibre.com 2017-12-27 11:02:11 UTC
Patch tested with a sandbox, by Björn Nylén <bjorn.nylen@ub.lu.se>
Comment 5 sandboxes@biblibre.com 2017-12-27 11:02:34 UTC
Created attachment 70169 [details] [review]
Bug 19798: Fix print transfer slip

... and maybe other bugs as well
What happens here is that $itemnumber is no longer set when barcode is
passed.

Test plan:
1. Check in available/not on hold item at a non owning library.
2. Click print slip
3. Item's info must be displayed on the slip

Signed-off-by: Björn Nylén <bjorn.nylen@ub.lu.se>
Signed-off-by: Björn Nylén <bjorn.nylen@ub.lu.se>
Comment 6 Jon Knight 2017-12-27 21:14:22 UTC
Created attachment 70181 [details] [review]
Bug 19798: Fix print transfer slip

... and maybe other bugs as well
What happens here is that $itemnumber is no longer set when barcode is
passed.

Test plan:
1. Check in available/not on hold item at a non owning library.
2. Click print slip
3. Item's info must be displayed on the slip

Signed-off-by: Björn Nylén <bjorn.nylen@ub.lu.se>
Signed-off-by: Björn Nylén <bjorn.nylen@ub.lu.se>
Signed-off-by: Jon Knight <J.P.Knight@lboro.ac.uk>
Comment 7 Katrin Fischer 2017-12-29 07:14:06 UTC
Created attachment 70198 [details] [review]
Bug 19798: Fix print transfer slip

... and maybe other bugs as well
What happens here is that $itemnumber is no longer set when barcode is
passed.

Test plan:
1. Check in available/not on hold item at a non owning library.
2. Click print slip
3. Item's info must be displayed on the slip

Signed-off-by: Björn Nylén <bjorn.nylen@ub.lu.se>
Signed-off-by: Björn Nylén <bjorn.nylen@ub.lu.se>
Signed-off-by: Jon Knight <J.P.Knight@lboro.ac.uk>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Jonathan Druart 2018-01-02 15:13:07 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 9 Nick Clemens 2018-01-15 16:47:06 UTC
Awesome work all, pushed to stable for 17.11.02
Comment 10 Fridolin SOMERS 2018-01-22 10:53:43 UTC
Bug 18276 not in 17.05.x