Bug 19835 - Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017)
Summary: Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017)
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic data support (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bernardo Gonzalez Kriegel
QA Contact: Josef Moravec
URL:
Keywords:
: 18123 (view as bug list)
Depends on:
Blocks: 20709 20710
  Show dependency treegraph
 
Reported: 2017-12-19 13:04 UTC by Katrin Fischer
Modified: 2019-10-14 19:58 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 19835: Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017) (215.33 KB, patch)
2018-04-26 15:28 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 19835: Fix repeatability on MARC21 subfields (66.03 KB, patch)
2018-04-26 15:29 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 19835: Fix MARC21 frameworks revision date (1.87 KB, patch)
2018-04-26 15:39 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 19835: Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017) (215.39 KB, patch)
2018-04-30 06:05 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19835: Fix repeatability on MARC21 subfields (66.09 KB, patch)
2018-04-30 06:05 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19835: Fix MARC21 frameworks revision date (1.93 KB, patch)
2018-04-30 06:05 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19835: (follow-up) Correct formatting in a few places (1.61 KB, patch)
2018-04-30 06:05 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19835: Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017) (215.45 KB, patch)
2018-06-04 12:34 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 19835: Fix repeatability on MARC21 subfields (66.14 KB, patch)
2018-06-04 12:34 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 19835: Fix MARC21 frameworks revision date (1.99 KB, patch)
2018-06-04 12:34 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 19835: (follow-up) Correct formatting in a few places (1.67 KB, patch)
2018-06-04 12:34 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2017-12-19 13:04:32 UTC
We should update our frameworks to reflect changes made with the last 2 MARC 21 updates:

http://www.loc.gov/marc/status.html
Comment 1 Bernardo Gonzalez Kriegel 2018-04-26 02:54:55 UTC
And update 23 (November 2016), so 3 updates.
Patch coming
Comment 2 Bernardo Gonzalez Kriegel 2018-04-26 15:28:58 UTC
Created attachment 74884 [details] [review]
Bug 19835: Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017)

There are a bunch of updates, summary below

1) Update 23
1.a) Bibs
New fields: 647 885
New subfields
e in 752
0 in 257 377
3 in 382
4 in 752

Changes
028 redefined
a renamed in 028
b renamed in 046
d renamed in 046

1.b) Auth
New Fields: 075 147 447 547 677 747 885
New Subfields: 0 in 377

2) Update 24
2.a) Bibs
New subfields
b in 567
g in 340
i in 370 386
0 in many fields
2 in 567
3 in 370
4 in 370 386

Changes
g renamed in 370
4 'Relationship code' -> 'Relationship' many fields
4 'Relator code'      -> 'Relationship' many fields

2.b) Auth
New subfields
i in 370 386
0 in 050 052 053 055 060 065 070 080 087
3 in 370
4 in 370 386

Changes
g in 370
4 'Relationship code' -> 'Relationship' many fields
4 'Relator code'      -> 'Relationship' in 371

3) Update 25
3.a) Bibs
New fields: 758
New subfields
r in 777
u in 777
z in 777
1 in many fields

Changes
d renamed in 111 611 711 811
s repeatable in many fields

3.b) Auth
New subfields
1 in many fields

Changes
d in 111 411 511 711
s repeatable in many fields

For more detail:
Update 23
bibs https://www.loc.gov/marc/up23bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/up23authority/adapndxf.html

Update 24
bibs https://www.loc.gov/marc/up24bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/up24authority/adapndxf.html

Update 25
bibs https://www.loc.gov/marc/bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/authority/adapndxf.html

To test:
1) Remove all your frameworks
2) Check mandatory bibliographic and authority files load without problem
3) Check new fields/subfields

Repeatability checks on followup
Comment 3 Bernardo Gonzalez Kriegel 2018-04-26 15:29:01 UTC
Created attachment 74885 [details] [review]
Bug 19835: Fix repeatability on MARC21 subfields

This followup fixes all repeatability cases, from
updates 23+24+25 and a few older ones.

To test:
0) Apply both patches
1) Remove all your frameworks
2) Check mandatory bibliographic and authority files load without problem
3) Check repeatability...

Bibs and auth frameworks checked against LOC description.
Comment 4 Bernardo Gonzalez Kriegel 2018-04-26 15:39:50 UTC
Created attachment 74886 [details] [review]
Bug 19835: Fix MARC21 frameworks revision date

This followup updates revison number and date
Comment 5 Katrin Fischer 2018-04-30 06:05:45 UTC
Created attachment 74930 [details] [review]
Bug 19835: Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017)

There are a bunch of updates, summary below

1) Update 23
1.a) Bibs
New fields: 647 885
New subfields
e in 752
0 in 257 377
3 in 382
4 in 752

Changes
028 redefined
a renamed in 028
b renamed in 046
d renamed in 046

1.b) Auth
New Fields: 075 147 447 547 677 747 885
New Subfields: 0 in 377

2) Update 24
2.a) Bibs
New subfields
b in 567
g in 340
i in 370 386
0 in many fields
2 in 567
3 in 370
4 in 370 386

Changes
g renamed in 370
4 'Relationship code' -> 'Relationship' many fields
4 'Relator code'      -> 'Relationship' many fields

2.b) Auth
New subfields
i in 370 386
0 in 050 052 053 055 060 065 070 080 087
3 in 370
4 in 370 386

Changes
g in 370
4 'Relationship code' -> 'Relationship' many fields
4 'Relator code'      -> 'Relationship' in 371

3) Update 25
3.a) Bibs
New fields: 758
New subfields
r in 777
u in 777
z in 777
1 in many fields

Changes
d renamed in 111 611 711 811
s repeatable in many fields

3.b) Auth
New subfields
1 in many fields

Changes
d in 111 411 511 711
s repeatable in many fields

For more detail:
Update 23
bibs https://www.loc.gov/marc/up23bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/up23authority/adapndxf.html

Update 24
bibs https://www.loc.gov/marc/up24bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/up24authority/adapndxf.html

Update 25
bibs https://www.loc.gov/marc/bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/authority/adapndxf.html

To test:
1) Remove all your frameworks
2) Check mandatory bibliographic and authority files load without problem
3) Check new fields/subfields

Repeatability checks on followup

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Katrin Fischer 2018-04-30 06:05:50 UTC
Created attachment 74931 [details] [review]
Bug 19835: Fix repeatability on MARC21 subfields

This followup fixes all repeatability cases, from
updates 23+24+25 and a few older ones.

To test:
0) Apply both patches
1) Remove all your frameworks
2) Check mandatory bibliographic and authority files load without problem
3) Check repeatability...

Bibs and auth frameworks checked against LOC description.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Katrin Fischer 2018-04-30 06:05:53 UTC
Created attachment 74932 [details] [review]
Bug 19835: Fix MARC21 frameworks revision date

This followup updates revison number and date

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Katrin Fischer 2018-04-30 06:05:56 UTC
Created attachment 74933 [details] [review]
Bug 19835: (follow-up) Correct formatting in a few places

In some places - was used insted of --, changed for
consistency with existing descriptions.
Comment 9 Katrin Fischer 2018-04-30 08:27:43 UTC
*** Bug 18123 has been marked as a duplicate of this bug. ***
Comment 10 Josef Moravec 2018-06-02 08:26:24 UTC
Good job Bernardo!

But I am missing the changes in codes... Could you please update value builders too?

Thanks
Comment 11 Katrin Fischer 2018-06-02 12:22:14 UTC
Hi Josef, there has been a separate bug 20700 - is that what you are missing?
Comment 12 Bernardo Gonzalez Kriegel 2018-06-03 01:02:15 UTC
(In reply to Josef Moravec from comment #10)
> But I am missing the changes in codes... Could you please update value
> builders too?

Hi Josef, as Katrin said code changes for update 23 were fixed on Bug 20700, plus some missing code changes from update 22.
Code changes for update 26 are in Bug 20710.

With those bugs and this I think we will be up to date :)
Comment 13 Josef Moravec 2018-06-04 12:27:25 UTC
(In reply to Bernardo Gonzalez Kriegel from comment #12)
> (In reply to Josef Moravec from comment #10)
> > But I am missing the changes in codes... Could you please update value
> > builders too?
> 
> Hi Josef, as Katrin said code changes for update 23 were fixed on Bug 20700,
> plus some missing code changes from update 22.
> Code changes for update 26 are in Bug 20710.
> 
> With those bugs and this I think we will be up to date :)



(In reply to Katrin Fischer from comment #11)
> Hi Josef, there has been a separate bug 20700 - is that what you are missing?

Yes, that's exactly what I was missing ;)
Comment 14 Josef Moravec 2018-06-04 12:28:00 UTC
(In reply to Bernardo Gonzalez Kriegel from comment #12)
> (In reply to Josef Moravec from comment #10)
> > But I am missing the changes in codes... Could you please update value
> > builders too?
> 
> Hi Josef, as Katrin said code changes for update 23 were fixed on Bug 20700,
> plus some missing code changes from update 22.
> Code changes for update 26 are in Bug 20710.
> 
> With those bugs and this I think we will be up to date :)

Thanks, then I am going to pass this one ;)
Comment 15 Josef Moravec 2018-06-04 12:34:22 UTC
Created attachment 75759 [details] [review]
Bug 19835: Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017)

There are a bunch of updates, summary below

1) Update 23
1.a) Bibs
New fields: 647 885
New subfields
e in 752
0 in 257 377
3 in 382
4 in 752

Changes
028 redefined
a renamed in 028
b renamed in 046
d renamed in 046

1.b) Auth
New Fields: 075 147 447 547 677 747 885
New Subfields: 0 in 377

2) Update 24
2.a) Bibs
New subfields
b in 567
g in 340
i in 370 386
0 in many fields
2 in 567
3 in 370
4 in 370 386

Changes
g renamed in 370
4 'Relationship code' -> 'Relationship' many fields
4 'Relator code'      -> 'Relationship' many fields

2.b) Auth
New subfields
i in 370 386
0 in 050 052 053 055 060 065 070 080 087
3 in 370
4 in 370 386

Changes
g in 370
4 'Relationship code' -> 'Relationship' many fields
4 'Relator code'      -> 'Relationship' in 371

3) Update 25
3.a) Bibs
New fields: 758
New subfields
r in 777
u in 777
z in 777
1 in many fields

Changes
d renamed in 111 611 711 811
s repeatable in many fields

3.b) Auth
New subfields
1 in many fields

Changes
d in 111 411 511 711
s repeatable in many fields

For more detail:
Update 23
bibs https://www.loc.gov/marc/up23bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/up23authority/adapndxf.html

Update 24
bibs https://www.loc.gov/marc/up24bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/up24authority/adapndxf.html

Update 25
bibs https://www.loc.gov/marc/bibliographic/bdapndxg.html
auth https://www.loc.gov/marc/authority/adapndxf.html

To test:
1) Remove all your frameworks
2) Check mandatory bibliographic and authority files load without problem
3) Check new fields/subfields

Repeatability checks on followup

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 16 Josef Moravec 2018-06-04 12:34:27 UTC
Created attachment 75760 [details] [review]
Bug 19835: Fix repeatability on MARC21 subfields

This followup fixes all repeatability cases, from
updates 23+24+25 and a few older ones.

To test:
0) Apply both patches
1) Remove all your frameworks
2) Check mandatory bibliographic and authority files load without problem
3) Check repeatability...

Bibs and auth frameworks checked against LOC description.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 17 Josef Moravec 2018-06-04 12:34:30 UTC
Created attachment 75761 [details] [review]
Bug 19835: Fix MARC21 frameworks revision date

This followup updates revison number and date

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 18 Josef Moravec 2018-06-04 12:34:34 UTC
Created attachment 75762 [details] [review]
Bug 19835: (follow-up) Correct formatting in a few places

In some places - was used insted of --, changed for
consistency with existing descriptions.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 19 Jonathan Druart 2018-06-05 16:47:12 UTC
RM: wait for the answer on bug 20709 comment 12 please.
Comment 20 Nick Clemens 2018-07-02 13:17:19 UTC
Awesome work all!

Pushed to master for 18.11
Comment 21 Martin Renvoize 2018-07-03 10:01:38 UTC
Pushed to 18.05.x for 18.05.02, I felt that although this is marked as an enhancement, many librarians would see it as a bug not being in sync with MARC21 guidelines.
Comment 22 Fridolin Somers 2018-07-04 15:50:52 UTC
(In reply to Martin Renvoize from comment #21)
> Pushed to 18.05.x for 18.05.02, I felt that although this is marked as an
> enhancement, many librarians would see it as a bug not being in sync with
> MARC21 guidelines.

Same for 17.11.x, will be in 17.11.08
Comment 23 Fridolin Somers 2018-07-04 15:51:22 UTC
Not pushed to 17.05.x