Bug 19837 - Add multiple patrons to a list by cardnumber
Summary: Add multiple patrons to a list by cardnumber
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords: Academy
: 19525 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-19 15:13 UTC by Owen Leonard
Modified: 2018-03-23 00:56 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19837 - Add multiple patrons to a list by barcode (6.23 KB, patch)
2017-12-19 15:25 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19837 - Add error feedback for duplicatred or unfound cardnumbers (3.37 KB, patch)
2018-01-03 01:42 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 19837 - Add multiple patrons to a list by barcode (6.28 KB, patch)
2018-01-04 15:38 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 19837 - Add error feedback for duplicatred or unfound cardnumbers (3.42 KB, patch)
2018-01-04 16:21 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19837: Add multiple patrons to a list by barcode (6.23 KB, patch)
2018-02-18 14:37 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19837: Add error feedback for duplicated or unfound cardnumbers (3.49 KB, patch)
2018-02-18 14:45 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2017-12-19 15:13:31 UTC
I have a pretty good start on a feature to allow patrons to be added to a list by scanning multiple barcodes. It needs better error-handling, though, so I'm hoping a better perlmonger can pitch in.
Comment 1 Owen Leonard 2017-12-19 15:25:04 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2017-12-27 21:55:27 UTC
*** Bug 19525 has been marked as a duplicate of this bug. ***
Comment 3 Nick Clemens 2018-01-03 01:42:06 UTC Comment hidden (obsolete)
Comment 4 Nick Clemens 2018-01-03 01:43:11 UTC
I added some error feedback, it could certainly be made prettier, take a look please Owen?

Ideally we would be able to add by borrowernumber as well, but I think that is for another bug
Comment 5 Owen Leonard 2018-01-04 15:14:58 UTC
Thanks Nick! I think it looks fine.
Comment 6 Nick Clemens 2018-01-04 15:38:20 UTC
Created attachment 70277 [details] [review]
Bug 19837 - Add multiple patrons to a list by barcode

This patch adds the interface change and basic functionality for an
option to add multiple patrons to a patron list by scanning barcodes.

To test, apply the patch and go to Tools -> Patron lists.

- Create a patron list if necessary, and got to the "Add patrons"
  screen.
- Test the process for adding patrons using the "Patron search" text
  input.
- Test the process for adding patrons using the "Enter multiple card
  numbers" option.

This should really have some error-handling added to it: Onscreen
messages when a non-existing patron card number is submitted or when a
patron already exists on the list.

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 7 Owen Leonard 2018-01-04 16:21:51 UTC
Created attachment 70278 [details] [review]
Bug 19837 - Add error feedback for duplicatred or unfound cardnumbers

To test:
1 - Enter some patrons on a list
2 - 'Enter multiple cardnumbers'
3 - Make sure to add some that are already in list, some that don't
    exist, and some new patrons
4 - Verify results are as expected with warnings

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 8 Katrin Fischer 2018-02-18 14:37:39 UTC
Created attachment 71910 [details] [review]
Bug 19837: Add multiple patrons to a list by barcode

This patch adds the interface change and basic functionality for an
option to add multiple patrons to a patron list by scanning barcodes.

To test, apply the patch and go to Tools -> Patron lists.

- Create a patron list if necessary, and got to the "Add patrons"
  screen.
- Test the process for adding patrons using the "Patron search" text
  input.
- Test the process for adding patrons using the "Enter multiple card
  numbers" option.

This should really have some error-handling added to it: Onscreen
messages when a non-existing patron card number is submitted or when a
patron already exists on the list.

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Katrin Fischer 2018-02-18 14:45:38 UTC
Created attachment 71911 [details] [review]
Bug 19837: Add error feedback for duplicated or unfound cardnumbers

To test:
1 - Enter some patrons on a list
2 - 'Enter multiple cardnumbers'
3 - Make sure to add some that are already in list, some that don't
    exist, and some new patrons
4 - Verify results are as expected with warnings

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Jonathan Druart 2018-02-18 19:49:53 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 11 Nick Clemens 2018-03-23 00:56:32 UTC
Enhancement, not backported for 17.11