Bug 19913 - Embedded HTML5 videos are broken
Summary: Embedded HTML5 videos are broken
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 18754
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-03 21:10 UTC by Jonathan Druart
Modified: 2018-06-04 20:15 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19913: Fix embedded HTML5 videos at the OPAC (1.71 KB, patch)
2018-01-03 21:15 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 19913: Fix embedded HTML5 videos at the OPAC (1.75 KB, patch)
2018-01-08 20:16 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 19913: Fix embedded HTML5 videos at the OPAC (1.80 KB, patch)
2018-01-09 01:13 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2018-01-03 21:10:27 UTC
The video element is badly generated.

Caused by commit 752aef4593f1aa2d64700bf9738e7e03907eb1cd
    Bug 18754: Translatability: Get rid of exposed tt directives in opac-detail.tt
Comment 1 Jonathan Druart 2018-01-03 21:15:54 UTC
Created attachment 70255 [details] [review]
Bug 19913: Fix embedded HTML5 videos at the OPAC

Caused by
commit 752aef4593f1aa2d64700bf9738e7e03907eb1cd
Bug 18754: Translatability: Get rid of exposed tt directives in opac-detail.tt

A space is missing between 'source' and 'src'

Test plan:
Set  HTML5MediaEnabled  to OPAC
Put a video link to 856$u
See the OPAC detail page, tab video, click the video
=> Should play with this patch applied

Note that this does not affect intranet
Comment 2 sandboxes@biblibre.com 2018-01-08 20:16:11 UTC
Patch tested with a sandbox, by George <george@nekls.org>
Comment 3 sandboxes@biblibre.com 2018-01-08 20:16:38 UTC
Created attachment 70333 [details] [review]
Bug 19913: Fix embedded HTML5 videos at the OPAC

Caused by
commit 752aef4593f1aa2d64700bf9738e7e03907eb1cd
Bug 18754: Translatability: Get rid of exposed tt directives in opac-detail.tt

A space is missing between 'source' and 'src'

Test plan:
Set  HTML5MediaEnabled  to OPAC
Put a video link to 856$u
See the OPAC detail page, tab video, click the video
=> Should play with this patch applied

Note that this does not affect intranet

Signed-off-by: George <george@nekls.org>
Comment 4 Nick Clemens 2018-01-09 01:13:40 UTC
Created attachment 70334 [details] [review]
Bug 19913: Fix embedded HTML5 videos at the OPAC

Caused by
commit 752aef4593f1aa2d64700bf9738e7e03907eb1cd
Bug 18754: Translatability: Get rid of exposed tt directives in opac-detail.tt

A space is missing between 'source' and 'src'

Test plan:
Set  HTML5MediaEnabled  to OPAC
Put a video link to 856$u
See the OPAC detail page, tab video, click the video
=> Should play with this patch applied

Note that this does not affect intranet

Signed-off-by: George <george@nekls.org>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 5 Jonathan Druart 2018-01-09 12:54:14 UTC
(In reply to sandboxes@biblibre.com from comment #2)
> Patch tested with a sandbox, by George <george@nekls.org>

George, I have modified your signed-off-by line to add your surname. I hope it is  ok with you.
Comment 6 Jonathan Druart 2018-01-09 12:55:27 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 7 George Williams (NEKLS) 2018-01-09 15:17:05 UTC
(In reply to Jonathan Druart from comment #5)
> (In reply to sandboxes@biblibre.com from comment #2)
> > Patch tested with a sandbox, by George <george@nekls.org>
> 
> George, I have modified your signed-off-by line to add your surname. I hope
> it is  ok with you.

Jonathan - not a problem.
Comment 8 Nick Clemens 2018-01-15 16:48:30 UTC
Awesome work all, pushed to stable for 17.11.02
Comment 9 Fridolin SOMERS 2018-01-22 11:25:20 UTC
Pushed to 17.05.x for v17.05.08