Bug 20066 - Remove forbidden patterns from .inc and .tt files
Summary: Remove forbidden patterns from .inc and .tt files
Status: RESOLVED DUPLICATE of bug 20538
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Indranil Das Gupta
QA Contact: Testopia
URL:
Keywords:
Depends on: 20053
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-22 19:32 UTC by Indranil Das Gupta
Modified: 2018-09-06 18:23 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 20066 - Remove forbidden patterns from .inc and .tt files (3.25 KB, patch)
2018-01-22 19:50 UTC, Indranil Das Gupta
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Indranil Das Gupta 2018-01-22 19:32:08 UTC
The following files contain forbidden patterns

a) includes/datatables.inc => [% interface %] instead of [% themelang %]

b) modules/opac-auth-MARCdetail.tt => hard-coded path

c) modules/opac-auth-detail.tt => hard-coded path

This patch removes these.
Comment 1 Indranil Das Gupta 2018-01-22 19:50:59 UTC
Created attachment 70810 [details] [review]
Bug 20066 - Remove forbidden patterns from .inc and .tt files

This patch removes the forbidden patterns from the following files:

a) datatables.inc => [% interface %] instead of [% themelang %]

b) opac-auth-MARCdetail.tt => hard-coded path to JS resource.

c) opac-auth-detail.tt => hard-coded path to JS resource.

Test plan
=========

1/ Apply the patch from Bug 20053 and run koha-qa.pl. The QA tool
   will throw up these 3 files as FAIL for forbidden patterns use.

2/ Now apply this patch and run koha-qa.pl. The result should now
   be OK.
Comment 2 M. Tompsett 2018-01-26 03:35:57 UTC
Bug 20053 removed the javascript type, and yet, this keeps it. It does not apply in any order. Please fix.
Comment 3 M. Tompsett 2018-09-06 18:23:18 UTC
While not really a duplicate, the Asset.pm template plugin basically corrected this issue intrinsically.

*** This bug has been marked as a duplicate of bug 20538 ***