Bug 20151 - Search is broken when stemming has no language
Summary: Search is broken when stemming has no language
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Target Milestone: ---
Assignee: Fridolin SOMERS
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-07 14:06 UTC by Fridolin SOMERS
Modified: 2018-10-24 09:13 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20151: always use current language for stemming (4.67 KB, patch)
2018-02-07 15:30 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 20151: always use current language for stemming (5.13 KB, patch)
2018-09-16 19:12 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 20151: always use current language for stemming (5.17 KB, patch)
2018-09-16 19:26 UTC, David Nind
Details | Diff | Splinter Review
Bug 20151: always use current language for stemming (5.24 KB, patch)
2018-10-09 08:31 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2018-02-07 14:06:24 UTC
When stemming is enable in catalog searching, C4::Search::_build_stemmed_operand will transform operand into stemmed operand using stemmer Lingua::Stem::Snowball with a specified language.
This stemmer returns undef is no language is defined.

In classic catalog search, current language is used.
But in other pages acqui/neworderbiblio.pl and cataloguing/addbooks.pl no language is defined so operand is empty.
Any search returns entire catalog.
Comment 1 Fridolin SOMERS 2018-02-07 15:30:30 UTC
Created attachment 71285 [details] [review]
Bug 20151: always use current language for stemming

When stemming is enable in catalog searching, C4::Search::_build_stemmed_operand will transform operand into stemmed operand using stemmer Lingua::Stem::Snowball with a specified language.
This stemmer returns undef is no language is defined.

In classic catalog search, current language is used.
But in other pages acqui/neworderbiblio.pl and cataloguing/addbooks.pl no language is defined so operand is empty.
Any search returns entire catalog.

This patch corrects by returning operand without change if no langage is defined in C4::Search::_build_stemmed_operand. And uses current langage in pages acqui/neworderbiblio.pl and cataloguing/addbooks.pl.

Test plan :
1) Enable system preferences QueryStemming and QueryWeightFields
2) Disable system preferences QueryAutoTruncate, QueryFuzzy and UseQueryParser
3) Perform an search in catalog (without index) that uses the stemming, for example "historical" will search "histor*"
4) Go to "Cataloging"
5) Perform a search on same word in "Cataloging search"
6) Without patch you have entire catalog, with patch you have correct number of results
7) Go to aquisition on a basket and click "Add to basket"
8) Perform search in "From an existing record"
9) Without patch you have entire catalog, with patch you have correct number of results
Comment 2 jmbroust 2018-03-12 16:03:12 UTC
Sorry, I can't reproduce the problem on sandbox 8.
One point on test plan needs an explanation : 
QueryAutoTruncate must be turned to 'automaticaly' or to "only if * is added' ?
Whatever I do, I never have the whole catalog as number of results.
I searched with the word 'france' and I had the same number of results or less results in cataloging search vs catalog search.
Am I missing something ? or problem with sandbox ?
Comment 3 Fridolin SOMERS 2018-06-08 08:02:35 UTC
(In reply to jmbroust from comment #2)
> Sorry, I can't reproduce the problem on sandbox 8.
> One point on test plan needs an explanation : 
> QueryAutoTruncate must be turned to 'automaticaly' or to "only if * is
> added' ?

2) Disable system preference QueryAutoTruncate
I mean "only if * is added"
Comment 4 Fridolin SOMERS 2018-09-16 19:12:21 UTC
Created attachment 78994 [details] [review]
Bug 20151: always use current language for stemming

When stemming is enabled, in catalog searching "C4::Search::_build_stemmed_operand" will transform query operand into stemmed operand using stemmer Lingua::Stem::Snowball with a specified language.
This stemmer returns undef stemmed operand if no language is defined.

In main catalog search (catalogue/search.pl) current language is used.
But in other pages "acqui/neworderbiblio.pl" and "cataloguing/addbooks.pl" no language is defined so stemmed operand is empty and so stemming is not applied.

This patch corrects by returning in "C4::Search::_build_stemmed_operand" operand without change if no langage is defined.
And uses current langage in pages "acqui/neworderbiblio.pl" and "cataloguing/addbooks.pl" so all catalog search uses stemming.

Test plan :
1) Enable system preferences QueryStemming and QueryWeightFields
2) Disable system preferences QueryAutoTruncate, QueryFuzzy and UseQueryParser
3) Go to intranet main page and click on "Search the catalog" tab
4) Perform a search (without index) that uses the stemming, for example searching for "years" will also match "year"
5) Note how many results you get, for example "year" gets 24 results and "years" gets 24 results
6) Go to "Cataloging" module
7) Perform a search on same word in "Cataloging search" tab
8) Note how many results you get
9) Without patch you get fewer results than first search (step 5) because stemming is not applied, for example "year" gets 11 results and "years" gets 15 results
10) With patch you get the same results as first search (step 5) because stemming is applied, for example "year" and "years" gets 24 results
11) Same tests in aquisition module
12) On a basket, click "Add to basket" and perform a search in "From an existing record"
Comment 5 Fridolin SOMERS 2018-09-16 19:17:54 UTC
I changed test plan after tests with David Nind on new koha-testing-docker.

Example with year/years works in this environment.
It may be easier for QA.
Comment 6 David Nind 2018-09-16 19:26:31 UTC
Created attachment 78997 [details] [review]
Bug 20151: always use current language for stemming

When stemming is enabled, in catalog searching "C4::Search::_build_stemmed_operand" will transform query operand into stemmed operand using stemmer Lingua::Stem::Snowball with a specified language.
This stemmer returns undef stemmed operand if no language is defined.

In main catalog search (catalogue/search.pl) current language is used.
But in other pages "acqui/neworderbiblio.pl" and "cataloguing/addbooks.pl" no language is defined so stemmed operand is empty and so stemming is not applied.

This patch corrects by returning in "C4::Search::_build_stemmed_operand" operand without change if no langage is defined.
And uses current langage in pages "acqui/neworderbiblio.pl" and "cataloguing/addbooks.pl" so all catalog search uses stemming.

Test plan :
1) Enable system preferences QueryStemming and QueryWeightFields
2) Disable system preferences QueryAutoTruncate, QueryFuzzy and UseQueryParser
3) Go to intranet main page and click on "Search the catalog" tab
4) Perform a search (without index) that uses the stemming, for example searching for "years" will also match "year"
5) Note how many results you get, for example "year" gets 24 results and "years" gets 24 results
6) Go to "Cataloging" module
7) Perform a search on same word in "Cataloging search" tab
8) Note how many results you get
9) Without patch you get fewer results than first search (step 5) because stemming is not applied, for example "year" gets 11 results and "years" gets 15 results
10) With patch you get the same results as first search (step 5) because stemming is applied, for example "year" and "years" gets 24 results
11) Same tests in aquisition module
12) On a basket, click "Add to basket" and perform a search in "From an existing record"

Signed-off-by: David Nind <david@davidnind.com>
Comment 7 Martin Renvoize 2018-10-09 08:30:38 UTC
I'd really love to see some tests added for this.. but as it's inside a C4 area I can't justifiably fail qa for that.

Generally, the code makes sense and doesn't appear to cause any regressions on testing and fixes a valid issue.

Passing QA
Comment 8 Martin Renvoize 2018-10-09 08:31:38 UTC
Created attachment 80253 [details] [review]
Bug 20151: always use current language for stemming

When stemming is enabled, in catalog searching "C4::Search::_build_stemmed_operand" will transform query operand into stemmed operand using stemmer Lingua::Stem::Snowball with a specified language.
This stemmer returns undef stemmed operand if no language is defined.

In main catalog search (catalogue/search.pl) current language is used.
But in other pages "acqui/neworderbiblio.pl" and "cataloguing/addbooks.pl" no language is defined so stemmed operand is empty and so stemming is not applied.

This patch corrects by returning in "C4::Search::_build_stemmed_operand" operand without change if no langage is defined.
And uses current langage in pages "acqui/neworderbiblio.pl" and "cataloguing/addbooks.pl" so all catalog search uses stemming.

Test plan :
1) Enable system preferences QueryStemming and QueryWeightFields
2) Disable system preferences QueryAutoTruncate, QueryFuzzy and UseQueryParser
3) Go to intranet main page and click on "Search the catalog" tab
4) Perform a search (without index) that uses the stemming, for example searching for "years" will also match "year"
5) Note how many results you get, for example "year" gets 24 results and "years" gets 24 results
6) Go to "Cataloging" module
7) Perform a search on same word in "Cataloging search" tab
8) Note how many results you get
9) Without patch you get fewer results than first search (step 5) because stemming is not applied, for example "year" gets 11 results and "years" gets 15 results
10) With patch you get the same results as first search (step 5) because stemming is applied, for example "year" and "years" gets 24 results
11) Same tests in aquisition module
12) On a basket, click "Add to basket" and perform a search in "From an existing record"

Signed-off-by: David Nind <david@davidnind.com>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 9 Nick Clemens 2018-10-09 16:26:03 UTC
Awesome work all!

Pushed to master for 18.11
Comment 10 Martin Renvoize 2018-10-15 12:51:12 UTC
Pushed to 18.05.x for 18.05.05
Comment 11 Fridolin SOMERS 2018-10-15 14:56:15 UTC
Pushed to 17.11.x for 17.11.11