Bug 20251 - Regression - SIP checkout broken
Summary: Regression - SIP checkout broken
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: SIP2 (show other bugs)
Version: master
Hardware: All All
: P5 - low blocker (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
Depends on: 19280
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-20 11:29 UTC by Colin Campbell
Modified: 2018-04-06 17:07 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20251: (bug 19280 follow-up) FIX SIP checkout (2.48 KB, patch)
2018-02-28 15:58 UTC, Jonathan Druart
Details | Diff | Splinter Review
Patch with signoff (2.54 KB, patch)
2018-03-01 14:44 UTC, Colin Campbell
Details | Diff | Splinter Review
Bug 20251: (bug 19280 follow-up) FIX SIP checkout (2.63 KB, patch)
2018-03-02 07:19 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Campbell 2018-02-20 11:29:49 UTC
Attempts to checkout via sip cause the sipserver to crash.

The interface to CanBookBeIssued was altered so it now requires a Koha::Patron object. When passed an oldstyle Patron hash it aborts on the call to unblessed.

Can be mitigated by retrieving a Patron object with
Koha::Patrons->find( { cardnumber => $borrower->{cardnumber}} );

in _can_we_issue sub of Checkout.pm but it may be time to look at rationalizing the patron handling in the SIP routines
Comment 1 Jonathan Druart 2018-02-28 15:53:27 UTC
Caused by
  commit d8dc86bc4bde4b5744cd0bc954e1e5767250dde2
    Bug 19280: Pass a Koha::Patron to CanBookBeIssued
Comment 2 Jonathan Druart 2018-02-28 15:58:12 UTC
Created attachment 72291 [details] [review]
Bug 20251: (bug 19280 follow-up) FIX SIP checkout
Comment 3 Jonathan Druart 2018-02-28 15:59:21 UTC
Hi Colin, thanks for catching that!
Does this patch make sense to you?
Comment 4 Colin Campbell 2018-03-01 14:44:24 UTC
Created attachment 72308 [details] [review]
Patch with signoff
Comment 5 Colin Campbell 2018-03-01 14:45:39 UTC
(In reply to Jonathan Druart from comment #3)
> Hi Colin, thanks for catching that!
> Does this patch make sense to you?

Yes, I've  ran tests doing issues and related operations and responses are ok
Comment 6 Marcel de Rooy 2018-03-02 06:38:02 UTC
QA: Looking here now
Comment 7 Marcel de Rooy 2018-03-02 07:19:56 UTC
Created attachment 72343 [details] [review]
Bug 20251: (bug 19280 follow-up) FIX SIP checkout

Signed-off-by: Colin Campbell <colin.campbell@ptfs-europe.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 8 Nick Clemens 2018-03-15 09:23:30 UTC
Pushed to master for 18.05, thanks to all for your hard work.
Comment 9 Nick Clemens 2018-04-06 17:07:32 UTC
Dependency not in stable.