Bug 20282 - Wrong attribute in template calls to match holding branch when adding/editing a course reserve item
Summary: Wrong attribute in template calls to match holding branch when adding/editing...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Course reserves (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Nick Clemens
QA Contact: Josef Moravec
URL:
Whiteboard:
Keywords:
Depends on: 15758
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-23 10:58 UTC by Nick Clemens
Modified: 2018-10-24 09:13 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20282: Match course reserve on holdingbranch (1.89 KB, patch)
2018-02-23 11:01 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 20282: Match course reserve on holdingbranch (1.94 KB, patch)
2018-03-09 20:16 UTC, Maksim Sen
Details | Diff | Splinter Review
Bug 20282: Match course reserve on holdingbranch (1.99 KB, patch)
2018-03-29 10:54 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2018-02-23 10:58:22 UTC
To recreate:
1 - Add a course
2 - Add an item to the course - change the holding library
3 - Edit the item, note the holding branch dropdown appears as 'unchanged'
Comment 1 Nick Clemens 2018-02-23 11:01:28 UTC
Created attachment 72112 [details] [review]
Bug 20282: Match course reserve on holdingbranch

To test:
1 - Add a course (Course Reserves)
2 - Add an item to the course
3 - Ensure to change the holding branch for the course reserve
4 - Modify the course item
5 - Note the dropdwn for holding branch is unset
6 - Apply patch
7 - Modify the course item
8 - Dropdown should be correctly populated
Comment 2 Maksim Sen 2018-03-09 20:16:56 UTC
Created attachment 72620 [details] [review]
Bug 20282: Match course reserve on holdingbranch

To test:
1 - Add a course (Course Reserves)
2 - Add an item to the course
3 - Ensure to change the holding branch for the course reserve
4 - Modify the course item
5 - Note the dropdwn for holding branch is unset
6 - Apply patch
7 - Modify the course item
8 - Dropdown should be correctly populated

Signed-off-by: Maksim Sen <maksim.sen@inlibro.com>
Comment 3 Josef Moravec 2018-03-29 10:54:51 UTC
Created attachment 73416 [details] [review]
Bug 20282: Match course reserve on holdingbranch

To test:
1 - Add a course (Course Reserves)
2 - Add an item to the course
3 - Ensure to change the holding branch for the course reserve
4 - Modify the course item
5 - Note the dropdwn for holding branch is unset
6 - Apply patch
7 - Modify the course item
8 - Dropdown should be correctly populated

Signed-off-by: Maksim Sen <maksim.sen@inlibro.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 4 Jonathan Druart 2018-04-02 19:49:48 UTC
Caused by
  commit 9b9803b69c8bde879768ccfa3cc4688ef46b7799
  Bug 15758: Koha::Libraries - Remove GetBranchesLoop
Comment 5 Jonathan Druart 2018-04-02 21:15:08 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 6 Nick Clemens 2018-05-14 21:22:32 UTC
Pushed to stable for 17.11.06

Awesome work all!
Comment 7 Fridolin SOMERS 2018-05-22 10:03:32 UTC
Pushed to 17.05.x for v17.05.12