Bug 20403 - Refactor "Keywords to marc mapping"
Summary: Refactor "Keywords to marc mapping"
Status: RESOLVED DUPLICATE of bug 11529
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 20396
  Show dependency treegraph
 
Reported: 2018-03-14 14:00 UTC by Gaetan Boisson
Modified: 2019-02-22 14:25 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gaetan Boisson 2018-03-14 14:00:08 UTC
I have not seen this in use in any library so far, and think this would be better if superseded by xslt, or extra columns in the biblio table.

Fridolyn also mentions that this leads to performance issues.

Would we benefit from dropping it?
Comment 1 Owen Leonard 2018-03-14 14:21:45 UTC
I feel strongly that we cannot consider dropping keywords to MARC mapping until we have a good way to handle subtitle in place to replace it.

As far as I know the feature could be renamed "subtitle configuration" since that's the only thing it's used for. However, it is used in a lot of places. Because multiple subfields can be configured at a time, a single subfield column in the biblio table would probably not be an adequate solution.
Comment 2 Gaetan Boisson 2018-03-14 16:24:12 UTC
I renamed this to "refactor" instead of "remove" since it is in fact used.

We do need to find a way to solve the performance issue, and have an interface that makes more sense than the current one.

I am in favor of adding columns to the biblio table, but it wouldn't be possible to have more than one field in one column.
Comment 3 Katrin Fischer 2018-03-17 08:57:34 UTC
We use this for displaying 245 $b $n $p in a lot of places. It's really needed still.
Comment 4 Fridolin SOMERS 2018-04-05 15:15:09 UTC
I think we should provide an XSLT transformation for all compact display of a biblio record.
Comment 5 Katrin Fischer 2018-04-05 18:57:19 UTC
I think it could be a performance issue.
Comment 6 Fridolin SOMERS 2019-02-22 14:22:28 UTC

*** This bug has been marked as a duplicate of bug 11529 ***
Comment 7 Fridolin SOMERS 2019-02-22 14:25:22 UTC
Thanks a lot to Ere for working on Bug 11529 that removes keywords to marc mapping.