Bug 20491 - Use "Date due" in table header of item table
Summary: Use "Date due" in table header of item table
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: helene
QA Contact: Testopia
URL:
Keywords: Academy
Depends on:
Blocks:
 
Reported: 2018-03-28 22:52 UTC by Magnus Enger
Modified: 2019-02-25 07:07 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 20491: Test plan: 1) Go to admin, then to MARC frameworks, then to default frameworks structure, then subfield stucture for 952 2) Verify that 'q' is described as 'checked out' 3) Go to <intranet>/cgi-bin/koha/cataloguing/additem.pl?biblionumber=x 4) (1.40 KB, patch)
2019-01-16 22:00 UTC, helene
Details | Diff | Splinter Review
Bug 20491: Updating the MARC subfield desciption of 952q (34.08 KB, patch)
2019-01-16 22:09 UTC, helene
Details | Diff | Splinter Review
Bug 20491: Updating the MARC subfield desciption of 952q (34.10 KB, patch)
2019-01-18 20:55 UTC, Pierre-Marc Thibault
Details | Diff | Splinter Review
Bug 20491: Updating the MARC subfield desciption of 952q (34.21 KB, patch)
2019-01-20 14:21 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 20491: (QA follow-up) Remove atomic update (1.03 KB, patch)
2019-01-20 14:21 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2018-03-28 22:52:55 UTC
On <intranet>/cgi-bin/koha/cataloguing/additem.pl?biblionumber=x there is a table of existing items. One of the columns is called "Checked out". I would assume this is the date the item was checked out, but it is in fact the due date (from items.onloan). It would be less confusing if this column was called "Date due" or something similar.
Comment 1 Katrin Fischer 2018-03-30 08:50:56 UTC
The description is pulled from the frameworks, probably never was changed after we switched the fields from being boolean to being a date. Not quite as easy of a fix as I hoped. We'd need to do a search and replace on all the frameworks still using this description for 952$q.

Of course it also means that for now you can easily change it in your installations, but a global fix would be nicer.
Comment 2 helene 2019-01-16 22:00:50 UTC Comment hidden (obsolete)
Comment 3 helene 2019-01-16 22:09:16 UTC
Created attachment 84099 [details] [review]
Bug 20491: Updating the MARC subfield desciption of 952q

Test plan:
1) Go to admin, then to MARC frameworks, then to default
frameworks structure, then subfield stucture for 952
2) Verify that 'q'
is described as 'checked out'
3) Go to <intranet>/cgi-bin/koha/cataloguing/additem.pl?biblionumber=x
4) Verify
that 'q' is also descirbed as 'Checked out' in
5) Apply patch and update
your database
6) Verify that the description of 'q' has changed to 'Date
due'
7) Go to <intranet>/cgi-bin/koha/cataloguing/additem.pl?biblionumber=x
6) Verify that it has changed to 'Date due'
Comment 4 Pierre-Marc Thibault 2019-01-18 20:55:16 UTC
Created attachment 84222 [details] [review]
Bug 20491: Updating the MARC subfield desciption of 952q

Test plan:
1) Go to admin, then to MARC frameworks, then to default
frameworks structure, then subfield stucture for 952
2) Verify that 'q'
is described as 'checked out'
3) Go to <intranet>/cgi-bin/koha/cataloguing/additem.pl?biblionumber=x
4) Verify
that 'q' is also descirbed as 'Checked out' in
5) Apply patch and update
your database
6) Verify that the description of 'q' has changed to 'Date
due'
7) Go to <intranet>/cgi-bin/koha/cataloguing/additem.pl?biblionumber=x
6) Verify that it has changed to 'Date due'

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>
Comment 5 Pierre-Marc Thibault 2019-01-18 21:00:42 UTC
I figured your first patch was not neccessary, so I put the tag obsolete on it and only tested the second one, it seems to work correctly. It's signed off :)
Comment 6 David Nind 2019-01-19 04:17:12 UTC
I was testing but didn't notice that it was already signed-off!

For the frameworks: I can confirm that this works as intended after the patch is applied.

For NEW items checked out: I can confirm that this works as intended for NEW items checked out after the patch is applied. That is, the column heading displays as 'Due date'.

For EXISTING items already checked out: It doesn't seem to work for EXISTING items checked out before the patch is applied. That is, the column heading stays as 'Checked out'.
- Is something required in the database update to update all existing checked out items?
- Is it something to do with caching? I restarted all services (using koha-testing-docker = restart_all), rebuilt the index (koha-rebuild-zebra -f -v kohadev), and used a browser with all the history completely cleared.
Comment 7 David Nind 2019-01-19 04:22:00 UTC
Also, a couple of things I noted that are probably obvious to those more familiar with Koha and testing:

- Test plan: Between steps 2 and 3, you need to check an item out for a record and use that record number for 'x' in step 3. Otherwise, the 'Checkout out' column doesn't display. This drove me a bit nuts trying to find the column (just kidding!).

- The patch involves database updates. If you remove the branch used to test the bug (for example, git branch -D bz20491) and reset your koha repository (git reset --hard origin/master) then the column still displays as 'Due date'. You need to either reset the database (however you do that) or refresh your development environment (koha-testing-docker = CTRL C, docker-compose -p koha down, docker-compose -p koha up).
Comment 8 Katrin Fischer 2019-01-20 14:19:39 UTC
I think this patch is ok, but should be pushed without the atomicupdate. 

The problem is that we kind of have a rule to not mess with people's existing framework setups. As such we don't add new fields there usually for the MARC updates etc. The other major problem is that people with translated frameworks would find their translations overwritten by the English term.

I am adding a follow-up removing the atomic-update, to be on the safe side, but it might be easier to do it on RM side :)
Comment 9 Katrin Fischer 2019-01-20 14:21:49 UTC
Created attachment 84250 [details] [review]
Bug 20491: Updating the MARC subfield desciption of 952q

Test plan:
1) Go to admin, then to MARC frameworks, then to default
frameworks structure, then subfield stucture for 952
2) Verify that 'q'
is described as 'checked out'
3) Go to <intranet>/cgi-bin/koha/cataloguing/additem.pl?biblionumber=x
4) Verify
that 'q' is also descirbed as 'Checked out' in
5) Apply patch and update
your database
6) Verify that the description of 'q' has changed to 'Date
due'
7) Go to <intranet>/cgi-bin/koha/cataloguing/additem.pl?biblionumber=x
6) Verify that it has changed to 'Date due'

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Katrin Fischer 2019-01-20 14:21:53 UTC
Created attachment 84251 [details] [review]
Bug 20491: (QA follow-up) Remove atomic update

We should not update existing installations, especially
since this would not work for translated frameworks.
Comment 11 Nick Clemens 2019-01-25 17:58:50 UTC
Awesome work all!

Pushed to master for 19.05
Comment 12 Martin Renvoize 2019-01-31 16:37:06 UTC
Pushed to 18.11.x for 18.11.03
Comment 13 Lucas Gass 2019-02-01 20:55:07 UTC
pushed to 18.05.x for 18.05.09
Comment 14 Fridolin SOMERS 2019-02-04 12:02:13 UTC
Pushed to 17.11.x for 17.11.15