Bug 20493 - SIP2 sending blank Title Identifier and Due date while Renew the books through Selfcheck
Summary: SIP2 sending blank Title Identifier and Due date while Renew the books throug...
Status: RESOLVED DUPLICATE of bug 21486
Alias: None
Product: Koha
Classification: Unclassified
Component: SIP2 (show other bugs)
Version: 17.05
Hardware: PC Windows
: P1 - high critical (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-29 11:12 UTC by Anil Tiwari
Modified: 2019-12-10 14:17 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
SIP2 Logs (969.72 KB, text/plain)
2018-03-29 11:12 UTC, Anil Tiwari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anil Tiwari 2018-03-29 11:12:59 UTC
Created attachment 73418 [details]
SIP2 Logs

Hi,

When we are renewing the books through Selfcheck Unit, the SIP2 is not sending the Item Identifier and Due Date, and because of this the Patrons are getting Item not checked out message. can you please look in to this. 

Parsing: 300NUN20180326    142806AAPSPHPS170013|AB104059|AJ|AH|AOMAIN|AFItem not checked out to SOUMITRA MIDYA|AY3AZE1C5
2018-03-26 14:27:44,123 INFO    [ 7] MessageFormatter - Parsed: [30] Renew Response {ok = 0, renewal ok = False, magnetic media = null, desensitize = False, transaction date = 2018-03-26 14:28:06, [AA] patron identifier = #d587bf42, [AB] item identifier = "104059", [AJ] title identifier = "", [AH] due date = "", [AO] institution id = "MAIN", [AF] screen message = "Item not checked out to SOUMITRA MIDYA"}
2018-03-26 14:27:44,123 DEBUG   [ 7] SipCirculationProvider - Duration of operation: 77 ms



SIP Logs attached for your reference.
Comment 1 Nick Clemens 2018-10-29 17:22:00 UTC
I suspect this is a duplicate of bug 21486 - the system isn't sending the checked out items initially, so the renewals don't get the correct info
Comment 2 Jonathan Druart 2019-12-10 14:17:35 UTC
Marked as duplicate, please reopen if still valid.

*** This bug has been marked as a duplicate of bug 21486 ***