Bug 20832 - Opac user page crash when there is an overdue fine and not any rental charge for a patron
Summary: Opac user page crash when there is an overdue fine and not any rental charge ...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Josef Moravec
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 20914 (view as bug list)
Depends on: 12001
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-29 11:46 UTC by Josef Moravec
Modified: 2018-07-26 10:54 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20832: Fix opac user profile page when there is overdue fine and no rental charge (1.46 KB, patch)
2018-05-29 11:50 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 20832: Fix opac user profile page when there is overdue fine and no rental charge (1.53 KB, patch)
2018-06-11 10:28 UTC, Andrew Isherwood
Details | Diff | Splinter Review
Bug 20832: Fix opac user profile page when there is overdue fine and no rental charge (1.61 KB, patch)
2018-06-12 14:02 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2018-05-29 11:46:08 UTC
To reproduce:
Have an overdue fine linked with specific item currently checked out to you
Do not have any unpaid rental fees
Go to your profile in opac : opac-user.pl

-> the page crash and you can see in log: Can't call method "get_column" on an undefined value at
/usr/share/koha/opac/cgi-bin/opac/opac-user.pl line 217
Comment 1 Josef Moravec 2018-05-29 11:50:24 UTC
Created attachment 75624 [details] [review]
Bug 20832: Fix opac user profile page when there is overdue fine and no rental charge

Test plan:
0) Do not apply the patch
1) Have an overdue fine linked with specific item currently checked out
to your patron
2) Do not have any unpaid rental fees
3) Go to this patron profile in opac - page opac-user.pl
4) The page crashes with "Can't call method "get_column" on an undefined
value at
/usr/share/koha/opac/cgi-bin/opac/opac-user.pl line 217" in log
5) Apply the patch
6) Restart plack
7) The page should working and show the right amounts for fines
Comment 2 Andrew Isherwood 2018-06-11 10:28:09 UTC
Created attachment 75945 [details] [review]
Bug 20832: Fix opac user profile page when there is overdue fine and no rental charge

Test plan:
0) Do not apply the patch
1) Have an overdue fine linked with specific item currently checked out
to your patron
2) Do not have any unpaid rental fees
3) Go to this patron profile in opac - page opac-user.pl
4) The page crashes with "Can't call method "get_column" on an undefined
value at
/usr/share/koha/opac/cgi-bin/opac/opac-user.pl line 217" in log
5) Apply the patch
6) Restart plack
7) The page should working and show the right amounts for fines

Signed-off-by: Andrew Isherwood <andrew.isherwood@ptfs-europe.com>
Comment 3 Jonathan Druart 2018-06-12 13:50:04 UTC
Silly copy/paste error caused by
  commit 51aa6db46c604aa202a3d8f8e5028557480efbd5
  Bug 12001: Move GetMemberAccountRecords to the Koha namespace
Comment 4 Jonathan Druart 2018-06-12 14:02:07 UTC
Created attachment 75969 [details] [review]
Bug 20832: Fix opac user profile page when there is overdue fine and no rental charge

Test plan:
0) Do not apply the patch
1) Have an overdue fine linked with specific item currently checked out
to your patron
2) Do not have any unpaid rental fees
3) Go to this patron profile in opac - page opac-user.pl
4) The page crashes with "Can't call method "get_column" on an undefined
value at
/usr/share/koha/opac/cgi-bin/opac/opac-user.pl line 217" in log
5) Apply the patch
6) Restart plack
7) The page should working and show the right amounts for fines

Signed-off-by: Andrew Isherwood <andrew.isherwood@ptfs-europe.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 5 Jonathan Druart 2018-06-12 14:04:08 UTC
*** Bug 20914 has been marked as a duplicate of this bug. ***
Comment 6 Nick Clemens 2018-06-15 10:45:36 UTC
Awesome work all!

Pushed to master for 18.11
Comment 7 Martin Renvoize 2018-06-15 11:50:41 UTC
Pushed to 18.05.x for 18.05.01
Comment 8 Fridolin SOMERS 2018-06-18 05:25:44 UTC
Depends on Bug 12001 not in 17.11.x
Comment 9 Fridolin SOMERS 2018-07-26 10:54:21 UTC
Even with Bug 12001 patch for 17.11.x this patch is not for 17.11.x