Bug 20899 - Patron name not showing on issuehistory.pl
Summary: Patron name not showing on issuehistory.pl
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Josef Moravec
URL:
Whiteboard:
Keywords:
Depends on: 18403
Blocks: 20934 21432
  Show dependency treegraph
 
Reported: 2018-06-08 03:23 UTC by Liz Rea
Modified: 2018-10-01 20:38 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20899: Fix patron's name display (1.76 KB, patch)
2018-06-12 14:15 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 20899: Fix patron's name display (1.83 KB, patch)
2018-06-12 14:47 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 20899: Fix patron's name display (1.88 KB, patch)
2018-06-13 15:10 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 20899: Fix patron's name display (1.89 KB, patch)
2018-06-13 16:28 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2018-06-08 03:23:42 UTC
Even with the prefs set to show the name, the name doesn't seem to be showing here since the feature for groups was pushed. 

To replicate: 

Issue an item, go to the biblio, click the circulation history for this tab. Note that the patron's name is not showing here.
Comment 1 Jonathan Druart 2018-06-12 14:13:22 UTC
Caused by
  commit fa54100dffe092e606f79b15692eedaf78f42e45
  Bug 18403: Use patron-title.inc when hidepatronname is used [SPECIFIC for issuehistory]
Comment 2 Jonathan Druart 2018-06-12 14:15:25 UTC
Created attachment 75975 [details] [review]
Bug 20899: Fix patron's name display

This is a follow-up for
  commit fa54100dffe092e606f79b15692eedaf78f42e45
  Bug 18403: Use patron-title.inc when hidepatronname is used [SPECIFIC for issuehistory]

We should use patron-title.inc to display (or hide) patron's info on the
checkout history view

Test plan:
Issue an item, go to the biblio, click the circulation history for this
tab.
Note that the patron's name is showing.
Comment 3 Martin Renvoize 2018-06-12 14:47:30 UTC
Created attachment 75998 [details] [review]
Bug 20899: Fix patron's name display

This is a follow-up for
  commit fa54100dffe092e606f79b15692eedaf78f42e45
  Bug 18403: Use patron-title.inc when hidepatronname is used [SPECIFIC for issuehistory]

We should use patron-title.inc to display (or hide) patron's info on the
checkout history view

Test plan:
Issue an item, go to the biblio, click the circulation history for this
tab.
Note that the patron's name is showing.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 4 Martin Renvoize 2018-06-12 14:48:07 UTC
Works as expected :)
Comment 5 Josef Moravec 2018-06-13 15:10:57 UTC
Created attachment 76027 [details] [review]
Bug 20899: Fix patron's name display

This is a follow-up for
  commit fa54100dffe092e606f79b15692eedaf78f42e45
  Bug 18403: Use patron-title.inc when hidepatronname is used [SPECIFIC for issuehistory]

We should use patron-title.inc to display (or hide) patron's info on the
checkout history view

Test plan:
Issue an item, go to the biblio, click the circulation history for this
tab.
Note that the patron's name is showing.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 6 Jonathan Druart 2018-06-13 16:28:37 UTC
Created attachment 76042 [details] [review]
Bug 20899: Fix patron's name display

This is a follow-up for
  commit fa54100dffe092e606f79b15692eedaf78f42e45
  Bug 18403: Use patron-title.inc when hidepatronname is used [SPECIFIC for issuehistory]

We should use patron-title.inc to display (or hide) patron's info on the
checkout history view

Test plan:
Issue an item, go to the biblio, click the circulation history for this
tab.
Note that the patron's name is showing.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 7 Jonathan Druart 2018-06-13 16:28:55 UTC
Patch amended, td tag was not closed!
Comment 8 Nick Clemens 2018-06-15 10:45:05 UTC
Awesome work all!

Pushed to master for 18.11
Comment 9 Martin Renvoize 2018-06-15 12:06:20 UTC
Pushed to 18.05.x for 18.05.01
Comment 10 Fridolin SOMERS 2018-06-18 05:51:31 UTC
Depends on Bug 18403 not in 17.11.x