Bug 20928 - Checkout status not showing patron
Summary: Checkout status not showing patron
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Josef Moravec
URL:
Keywords:
Depends on: 18403
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-13 07:52 UTC by Stefan Berndtsson
Modified: 2019-10-14 19:58 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 20928: Fix regression - display patron's info on moredetail if item is checked out (2.10 KB, patch)
2018-06-14 14:45 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 20928: Fix regression - display patron's info on moredetail if item is checked out (2.19 KB, patch)
2018-06-15 19:11 UTC, Maryse Simard
Details | Diff | Splinter Review
Bug 20928: Fix regression - display patron's info on moredetail if item is checked out (2.24 KB, patch)
2018-06-18 14:59 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Berndtsson 2018-06-13 07:52:02 UTC
When looking at the item list (moredetail.pl) for a bibliographic record, there is no "Checked out to" patron linked. 

It seems holdpatronname is no longer sent to the template "moredetail.tt". I assume this means something has changed in how patron links are done, but the template still seem to use the old way of doing it.
Comment 1 Jonathan Druart 2018-06-14 14:42:49 UTC
Caused by
  commit 5f80977875ff124d411f2cd89de4a944fa9c27af
  Bug 18403: Use patron-title.inc when hidepatronname is used
Comment 2 Jonathan Druart 2018-06-14 14:45:37 UTC
Created attachment 76058 [details] [review]
Bug 20928: Fix regression - display patron's info on moredetail if item is checked out

This patch is a follow-up of
  commit 5f80977875ff124d411f2cd89de4a944fa9c27af
  Bug 18403: Use patron-title.inc when hidepatronname is used

Test plan:
- Check an item out
- Go on the moredetail.pl page of this biblio record
Home › Catalog › Item details for your biblio
- Confirm that you see:
"Checkout status: Checked out to"
followed by the patron's info
Comment 3 Maryse Simard 2018-06-15 19:11:38 UTC
Created attachment 76105 [details] [review]
Bug 20928: Fix regression - display patron's info on moredetail if item is checked out

This patch is a follow-up of
  commit 5f80977875ff124d411f2cd89de4a944fa9c27af
  Bug 18403: Use patron-title.inc when hidepatronname is used

Test plan:
- Check an item out
- Go on the moredetail.pl page of this biblio record
Home › Catalog › Item details for your biblio
- Confirm that you see:
"Checkout status: Checked out to"
followed by the patron's info

Signed-off-by: Maryse Simard <maryse.simard@inlibro.com>
Followed the test plan and it works.
Comment 4 Josef Moravec 2018-06-18 14:59:36 UTC
Created attachment 76138 [details] [review]
Bug 20928: Fix regression - display patron's info on moredetail if item is checked out

This patch is a follow-up of
  commit 5f80977875ff124d411f2cd89de4a944fa9c27af
  Bug 18403: Use patron-title.inc when hidepatronname is used

Test plan:
- Check an item out
- Go on the moredetail.pl page of this biblio record
Home › Catalog › Item details for your biblio
- Confirm that you see:
"Checkout status: Checked out to"
followed by the patron's info

Signed-off-by: Maryse Simard <maryse.simard@inlibro.com>
Followed the test plan and it works.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 5 Nick Clemens 2018-06-22 13:49:55 UTC
Awesome work all!

Pushed to master for 18.11.x
Comment 6 Martin Renvoize 2018-06-25 17:20:38 UTC
Pushed to 18.05.x for 18.05.02
Comment 7 Fridolin Somers 2018-06-28 05:50:10 UTC
Depends on Bug 18403 not in 17.11.x