Bug 21042 - Pay amount does not mark lost items as returned when those accountlines are paid
Summary: Pay amount does not mark lost items as returned when those accountlines are paid
Status: RESOLVED DUPLICATE of bug 22982
Alias: None
Product: Koha
Classification: Unclassified
Component: Fines and fees (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-05 18:04 UTC by Nick Clemens
Modified: 2019-05-28 11:36 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21042: Make 'pay amount' also return lost fines (1.26 KB, patch)
2018-07-05 18:08 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 21042: Make 'pay amount' also return lost fines (1.37 KB, patch)
2019-04-26 21:53 UTC, Marie-Luce Laflamme
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2018-07-05 18:04:56 UTC
This is problematic - if I click pay selected the item is returned, but pay amount and clearing the fines doesn't return it
Comment 1 Nick Clemens 2018-07-05 18:08:06 UTC
Created attachment 76711 [details] [review]
Bug 21042:  Make 'pay amount' also return lost fines

To test:
1 - Checkout an item to a patron, and make it lost ( but not returned)
    and ensure fine is levied against the account
2 - Add some other fines to their account
3 - Click 'Pay amount' and pay everything they owe
4 - Note the book is not returned
5 - Repeat with 'Pay selected' and note item is returned
6 - Apply patch
7 - Repeat 1-5 and note item is returned in both cases
Comment 2 Nick Clemens 2018-07-05 18:08:34 UTC
Note, I did not test this patch, it also presumably suffers from bug 19876
Comment 3 Brian 2018-12-15 18:22:15 UTC
Any updates

Carnegie team
Comment 4 Marie-Luce Laflamme 2019-04-26 21:53:03 UTC Comment hidden (obsolete)
Comment 5 Marie-Luce Laflamme 2019-05-03 19:13:49 UTC
The item seems do be removed from the check out list after making the item lost without applying the patch.

My system preferences MarkLostItemsAsReturned had no selected field.
Comment 6 Kyle M Hall 2019-05-28 11:36:12 UTC

*** This bug has been marked as a duplicate of bug 22982 ***