Bug 21225 - Add Syndetics cover images to staff client
Summary: Add Syndetics cover images to staff client
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff interface (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Lucas Gass
QA Contact: Testopia
URL:
Keywords:
: 31111 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-14 20:42 UTC by Cab Vinton
Modified: 2022-07-11 14:59 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00


Attachments
Bug 21225: Add Syndetics cover images to staff client. (9.10 KB, patch)
2021-02-16 10:23 UTC, Andreas Jonsson
Details | Diff | Splinter Review
Bug 21225: Add Syndetics cover images to staff client. (7.72 KB, patch)
2021-08-06 15:36 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 21225: Add Syndetics cover images to staff client. (7.51 KB, patch)
2022-02-15 18:57 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 21225: (follow-up) Make SyndeticCovers work on catalog detail page (2.25 KB, patch)
2022-02-15 23:01 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 21225: (follow-up) Account for Syndetics lightbox (2.86 KB, patch)
2022-02-16 17:52 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 21225: (follow-up) Account for Syndetics lightbox (2.81 KB, patch)
2022-02-16 18:32 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 21225: Add Syndetics cover images to staff client. (7.58 KB, patch)
2022-02-16 18:46 UTC, Biblibre Sandboxes
Details | Diff | Splinter Review
Bug 21225: (follow-up) Make SyndeticCovers work on catalog detail page (2.31 KB, patch)
2022-02-16 18:46 UTC, Biblibre Sandboxes
Details | Diff | Splinter Review
Bug 21225: (follow-up) Account for Syndetics lightbox (2.87 KB, patch)
2022-02-16 18:46 UTC, Biblibre Sandboxes
Details | Diff | Splinter Review
Bug 21225: (follow-up) correct filters (2.26 KB, patch)
2022-03-28 17:20 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 21225: Add Syndetics cover images to staff client. (7.63 KB, patch)
2022-03-28 21:17 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 21225: (follow-up) Make SyndeticCovers work on catalog detail page (2.37 KB, patch)
2022-03-28 21:17 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 21225: (follow-up) Account for Syndetics lightbox (2.93 KB, patch)
2022-03-28 21:17 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 21225: (follow-up) correct filters (2.31 KB, patch)
2022-03-28 21:17 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 21225: (QA follow-up) Update pref description of SyndeticsCoverImages (1.19 KB, patch)
2022-03-28 21:22 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Cab Vinton 2018-08-14 20:42:31 UTC
Syndetics enhanced content is currently only available in the OPAC.

It would be helpful if content were also available in the staff client (as it is for NoveList, for example).
Comment 1 Andreas Jonsson 2021-02-16 10:23:28 UTC
Created attachment 116911 [details] [review]
Bug 21225: Add Syndetics cover images to staff client.
Comment 2 Lucas Gass 2021-05-06 00:58:10 UTC
Andreas,


Sadly, this patch no longer applies cleanly to master. Is there any chance for a rebase?
Comment 3 Magnus Enger 2021-05-06 07:03:39 UTC
A test plan would also be great. :-)
Comment 4 Barbara Johnson 2021-05-20 21:57:43 UTC
We’d love for our Syndetics content to display in staff, especially the cover images for DVDs, since Amazon does not display those.  Our staff would be better able to help our patrons if they were able to see these cover images.  It would also save them time from having to switch to the OPAC to see a DVD cover image.

Is it possible to rebase the patch and provide a test plan so we could get this one moving?
Comment 5 Nick Clemens 2021-08-06 15:36:33 UTC
Created attachment 123581 [details] [review]
Bug 21225: Add Syndetics cover images to staff client.

This patch adds support for Syndetics Cover Images to the staff client

To test:
1 - Enable system preferences:
    SyndeticsEnabled
    SyndeticsCoverImages
    SyndeticsClientCode (you will need a valid code for testing)
2 - Perform a search on the staff client
3 - Check that results have images if upc,oclc number, or isbn existin record
4 - Confirm that dtails paeg displays same image
5 - Confirm size on details page follows syspref  SyndeticsCoverImageSize
Comment 6 Barbara Johnson 2021-08-06 19:19:31 UTC
Cover images display fine in the results pages.  However, sometimes they display on the detail pages and sometimes they don’t.  It appears that even though the ISBN is present in the 020 tag, the images won’t display on detail pages unless they also have an OCLC # in the O35 tag.
Comment 7 Katrin Fischer 2021-08-06 22:03:00 UTC
Setting to Failed QA because of comment#6
Comment 8 Barbara Johnson 2021-12-29 16:39:36 UTC
Just checking on the status of this one.  We would love to be able to see Syndetics covers in the staff client, especially for DVDs, and other materials that Amazon doesn't have covers for such as Playaways.
Comment 9 Lucas Gass 2022-02-15 18:57:42 UTC
Created attachment 130638 [details] [review]
Bug 21225: Add Syndetics cover images to staff client.

To test:
1 - Enable system preferences:
    SyndeticsEnabled
    SyndeticsCoverImages
    SyndeticsClientCode (you will need a valid code for testing)
2 - Perform a search on the staff client
3 - Check that results have images if upc,oclc number, or isbn existin record
4 - Confirm that dtails paeg displays same image
5 - Confirm size on details page follows syspref  SyndeticsCoverImageSize
Comment 10 Lucas Gass 2022-02-15 18:58:09 UTC
rebased for current master
Comment 11 Lucas Gass 2022-02-15 23:01:16 UTC
Created attachment 130640 [details] [review]
Bug 21225: (follow-up) Make SyndeticCovers work on catalog detail page
Comment 12 Barbara Johnson 2022-02-16 15:24:59 UTC
I tested again and it is working better.  

Here's the latest:

• Bib with ISBN only in the 020 - cover images display on results and details
• Bib with UPC only in the 024_1 - cover images display on results and details
• Bib with and 020 or 024_1 along with the 035 - cover images display on results and details
• Bib with OCLC # only in the 035 - cover images do not display - I tested this in my staff interface and it was the same so I don't think they are supposed to display if the bib only has an OCLC#
• Clicking on the Syndetics cover image from the details page - brings up a page with just a spinning loader icon instead of displaying an enlarged image as it does with an Amazon cover
• Two cover image services enabled - everything worked as outlined above with both Amazon and Syndetics enabled
• Cover images that display in the staff interface also display in the OPAC
Comment 13 Lucas Gass 2022-02-16 17:52:19 UTC
Created attachment 130689 [details] [review]
Bug 21225: (follow-up) Account for Syndetics lightbox

To test:
-Make sure when you apply all the patches that when you click on the Syndetics image in the detail page that it correctly displays the lightbox.
-Turn on some other cover image services and make sure you can toggle through each of them.
Comment 14 Barbara Johnson 2022-02-16 18:18:15 UTC
Clicking on the Syndetics image in the detail page now displays the image in the lightbox.  However, it is the same size image used on the detail page.  When doing this with an Amazon image the detail page shows a smaller image but in the lightbox it is enlarged so you can see more detail.
Comment 15 Lucas Gass 2022-02-16 18:32:53 UTC
Created attachment 130690 [details] [review]
Bug 21225: (follow-up) Account for Syndetics lightbox

To test:
-Make sure when you apply all the patches that when you click on the Syndetics image in the detail page that it correctly displays the lightbox.
-Turn on some other cover image services and make sure you can toggle through each of them.
Comment 16 Biblibre Sandboxes 2022-02-16 18:46:40 UTC
Created attachment 130696 [details] [review]
Bug 21225: Add Syndetics cover images to staff client.

To test:
1 - Enable system preferences:
    SyndeticsEnabled
    SyndeticsCoverImages
    SyndeticsClientCode (you will need a valid code for testing)
2 - Perform a search on the staff client
3 - Check that results have images if upc,oclc number, or isbn existin record
4 - Confirm that dtails paeg displays same image
5 - Confirm size on details page follows syspref  SyndeticsCoverImageSize

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>
Comment 17 Biblibre Sandboxes 2022-02-16 18:46:44 UTC
Created attachment 130697 [details] [review]
Bug 21225: (follow-up) Make SyndeticCovers work on catalog detail page

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>
Comment 18 Biblibre Sandboxes 2022-02-16 18:46:49 UTC
Created attachment 130698 [details] [review]
Bug 21225: (follow-up) Account for Syndetics lightbox

To test:
-Make sure when you apply all the patches that when you click on the Syndetics image in the detail page that it correctly displays the lightbox.
-Turn on some other cover image services and make sure you can toggle through each of them.

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>
Comment 19 Barbara Johnson 2022-02-16 18:48:24 UTC
Everything worked and looked great.
Comment 20 Katrin Fischer 2022-03-27 14:32:57 UTC
Can you please check the filter issues noted by the QA test tools? As I can't test with Syndetics, I don't want to mess with it:

 FAIL	koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt
   FAIL	  filters
		wrong_html_filter at line 243 (                            <a href="https://secure.syndetics.com/index.aspx?isbn=[% normalized_isbn | html %]/LC.GIF&amp;client=[% Koha.Preference('SyndeticsClientCode') | html %]&amp;type=xw10&amp;upc=[% normalized_upc | html %]&amp;oclc=[% normalized_oclc | html %]" title="Syndetics cover image">)
		wrong_html_filter at line 243 (                            <a href="https://secure.syndetics.com/index.aspx?isbn=[% normalized_isbn | html %]/LC.GIF&amp;client=[% Koha.Preference('SyndeticsClientCode') | html %]&amp;type=xw10&amp;upc=[% normalized_upc | html %]&amp;oclc=[% normalized_oclc | html %]" title="Syndetics cover image">)
		wrong_html_filter at line 243 (                            <a href="https://secure.syndetics.com/index.aspx?isbn=[% normalized_isbn | html %]/LC.GIF&amp;client=[% Koha.Preference('SyndeticsClientCode') | html %]&amp;type=xw10&amp;upc=[% normalized_upc | html %]&amp;oclc=[% normalized_oclc | html %]" title="Syndetics cover image">)
		wrong_html_filter at line 243 (                            <a href="https://secure.syndetics.com/index.aspx?isbn=[% normalized_isbn | html %]/LC.GIF&amp;client=[% Koha.Preference('SyndeticsClientCode') | html %]&amp;type=xw10&amp;upc=[% normalized_upc | html %]&amp;oclc=[% normalized_oclc | html %]" title="Syndetics cover image">)
Comment 21 Lucas Gass 2022-03-28 17:20:19 UTC
Created attachment 132357 [details] [review]
Bug 21225: (follow-up) correct filters
Comment 22 Katrin Fischer 2022-03-28 21:17:28 UTC
Created attachment 132366 [details] [review]
Bug 21225: Add Syndetics cover images to staff client.

To test:
1 - Enable system preferences:
    SyndeticsEnabled
    SyndeticsCoverImages
    SyndeticsClientCode (you will need a valid code for testing)
2 - Perform a search on the staff client
3 - Check that results have images if upc,oclc number, or isbn existin record
4 - Confirm that dtails paeg displays same image
5 - Confirm size on details page follows syspref  SyndeticsCoverImageSize

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 23 Katrin Fischer 2022-03-28 21:17:33 UTC
Created attachment 132367 [details] [review]
Bug 21225: (follow-up) Make SyndeticCovers work on catalog detail page

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 24 Katrin Fischer 2022-03-28 21:17:39 UTC
Created attachment 132368 [details] [review]
Bug 21225: (follow-up) Account for Syndetics lightbox

To test:
-Make sure when you apply all the patches that when you click on the Syndetics image in the detail page that it correctly displays the lightbox.
-Turn on some other cover image services and make sure you can toggle through each of them.

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 25 Katrin Fischer 2022-03-28 21:17:44 UTC
Created attachment 132369 [details] [review]
Bug 21225: (follow-up) correct filters

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 26 Katrin Fischer 2022-03-28 21:22:32 UTC
Created attachment 132370 [details] [review]
Bug 21225: (QA follow-up) Update pref description of SyndeticsCoverImages
Comment 27 Katrin Fischer 2022-03-28 21:27:26 UTC
I wonder if it would make sense to have a separate preference, but I think we can leave that to the libraries using Syndetics :)
Comment 28 Fridolin Somers 2022-04-08 13:52:27 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 29 Lucas Gass 2022-07-11 14:59:43 UTC
*** Bug 31111 has been marked as a duplicate of this bug. ***