Bug 21374 - Self registration e-mail verification does not work
Summary: Self registration e-mail verification does not work
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Josef Moravec
QA Contact: Testopia
URL:
Keywords:
Depends on: 20287
Blocks: 20819
  Show dependency treegraph
 
Reported: 2018-09-18 20:26 UTC by Josef Moravec
Modified: 2019-10-14 19:58 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21374: Fix self registration verification (1.37 KB, patch)
2018-09-18 20:33 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 21374: Fix self registration verification (1.42 KB, patch)
2018-09-19 09:47 UTC, Michal Denar
Details | Diff | Splinter Review
Bug 21374: Fix self registration verification (1.50 KB, patch)
2018-09-19 21:09 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2018-09-18 20:26:51 UTC
To reproduce:
Set PatronSelfRegistration  to Allow
Set PatronSelfRegistrationVerifyByEmail to Require
Try to create a account using self registration and verify it (use link in e-mail or take the url from table mesage_queue ;)
The verificatin url return ISE - DBIx::Class::Row::store_column(): No such column 'timestamp' on Koha::Schema::Result::Borrower
Comment 1 Josef Moravec 2018-09-18 20:33:16 UTC
Created attachment 79061 [details] [review]
Bug 21374: Fix self registration verification

Test plan:
0) Do not apply the patch
1) Set PatronSelfRegistration  to Allow
2) Set PatronSelfRegistrationVerifyByEmail to Require
3) Try to create a account using self registration and verify it (use link
    in e-mail or take the url from table mesage_queue ;)
    The verificatin url return ISE - DBIx::Class::Row::store_column(): No
    such column 'timestamp' on Koha::Schema::Result::Borrower
4) Apply the patch
5) Try to acces the verification url again - now it should work

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 2 Michal Denar 2018-09-19 09:47:45 UTC
Created attachment 79085 [details] [review]
Bug 21374: Fix self registration verification

Test plan:
0) Do not apply the patch
1) Set PatronSelfRegistration  to Allow
2) Set PatronSelfRegistrationVerifyByEmail to Require
3) Try to create a account using self registration and verify it (use link
    in e-mail or take the url from table mesage_queue ;)
    The verificatin url return ISE - DBIx::Class::Row::store_column(): No
    such column 'timestamp' on Koha::Schema::Result::Borrower
4) Apply the patch
5) Try to acces the verification url again - now it should work

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Michal Denar <black23@gmail.com>
Comment 3 Jonathan Druart 2018-09-19 21:03:12 UTC
Caused by
  commit cfbc53bb22e6f4a851a2a7cd6ede891012951410
  Bug 20287: Add plain_text_password (& Remove AddMember_Opac)
Comment 4 Jonathan Druart 2018-09-19 21:09:11 UTC
Created attachment 79126 [details] [review]
Bug 21374: Fix self registration verification

Test plan:
0) Do not apply the patch
1) Set PatronSelfRegistration  to Allow
2) Set PatronSelfRegistrationVerifyByEmail to Require
3) Try to create a account using self registration and verify it (use link
    in e-mail or take the url from table mesage_queue ;)
    The verificatin url return ISE - DBIx::Class::Row::store_column(): No
    such column 'timestamp' on Koha::Schema::Result::Borrower
4) Apply the patch
5) Try to acces the verification url again - now it should work

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Michal Denar <black23@gmail.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 5 Nick Clemens 2018-09-20 13:46:08 UTC
Awesome work all!

Pushed to master for 18.11
Comment 6 Martin Renvoize 2018-09-24 12:39:55 UTC
Bug that caused this is not in 18.05.x series, no need to backport.