Bug 21441 - System information gives reference to a non-existant table
Summary: System information gives reference to a non-existant table
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: About (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Katrin Fischer
QA Contact: Martin Renvoize
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-27 16:17 UTC by Christopher Brannon
Modified: 2019-02-25 10:12 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21441: Fix wrong reference to a 'holds' table on system information tab (1.46 KB, patch)
2019-02-04 23:44 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 21441: Fix wrong reference to a 'holds' table on system information tab (1.50 KB, patch)
2019-02-05 13:16 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21441: Fix wrong reference to a 'holds' table on system information tab (1.57 KB, patch)
2019-02-08 16:32 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Brannon 2018-09-27 16:17:42 UTC
EXAMPLE:

Data problems

Some of your tables have problems with their auto_increment values which may lead to data loss.

You should not ignore this warning.

The problem is that InnoDB does not keep auto_increment across SQL server restarts (it is only set in memory). So on server startup the auto_increment values are set to max(table.id)+1.

To know how to avoid this problem see the related wiki page: DBMS auto increment fix
Problems found
Holds

The following ids exist in both tables holds and old_reserves:

1, 2, 3

NOTE: The error refers to: both tables holds and old_reserves

There is no holds table.  It should read reserves.
Comment 1 Katrin Fischer 2019-02-04 23:44:19 UTC
Created attachment 84759 [details] [review]
Bug 21441: Fix wrong reference to a 'holds' table on system information tab

It looks like a typo snuck in on the about page, listing a holds
table instead of reserves.

To test:
- Manually create the same PK (reserve_id) in reserves and old_reserves
- Verify that the message on about > system information now
  correctly lists those tables (not holds and old_reserves)
Comment 2 Katrin Fischer 2019-02-04 23:44:45 UTC
Good catch!
Comment 3 Owen Leonard 2019-02-05 13:16:42 UTC
Created attachment 84766 [details] [review]
Bug 21441: Fix wrong reference to a 'holds' table on system information tab

It looks like a typo snuck in on the about page, listing a holds
table instead of reserves.

To test:
- Manually create the same PK (reserve_id) in reserves and old_reserves
- Verify that the message on about > system information now
  correctly lists those tables (not holds and old_reserves)

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 4 Martin Renvoize 2019-02-08 16:32:01 UTC
Created attachment 84879 [details] [review]
Bug 21441: Fix wrong reference to a 'holds' table on system information tab

It looks like a typo snuck in on the about page, listing a holds
table instead of reserves.

To test:
- Manually create the same PK (reserve_id) in reserves and old_reserves
- Verify that the message on about > system information now
  correctly lists those tables (not holds and old_reserves)

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 5 Martin Renvoize 2019-02-08 16:32:20 UTC
Simple one to QA.. Passed
Comment 6 Nick Clemens 2019-02-11 18:38:03 UTC
Awesome work all!

Pushed to master for 19.05
Comment 7 Martin Renvoize 2019-02-12 13:19:20 UTC
Pushed to 18.11.x for 18.11.03
Comment 8 Lucas Gass 2019-02-14 23:16:45 UTC
backported to 18.05.x for 18.05.09
Comment 9 Fridolin SOMERS 2019-02-25 10:12:27 UTC
Pushed to 17.11.x for 17.11.15