Bug 21463 - Library is no longer displayed in the overdue list
Summary: Library is no longer displayed in the overdue list
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 18789
Blocks: 15139 21464
  Show dependency treegraph
 
Reported: 2018-10-01 16:41 UTC by Jonathan Druart
Modified: 2019-10-14 19:56 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21463: (bug 18789 follow-up) Fix library display on the overdue list view (2.27 KB, patch)
2018-10-01 16:44 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21463: (bug 18789 follow-up) Fix library display on the overdue list view (2.34 KB, patch)
2018-10-05 20:19 UTC, Pierre-Marc Thibault
Details | Diff | Splinter Review
Bug 21463: (bug 18789 follow-up) Fix library display on the overdue list view (2.39 KB, patch)
2018-10-06 19:31 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2018-10-01 16:41:56 UTC
Caused by
  commit 0ab22e1c7c6b6e8d14a4fb7478ab2a3d42da347d
  Bug 18789: Send Koha::Patron object to the templates
Comment 1 Jonathan Druart 2018-10-01 16:44:07 UTC
Created attachment 79745 [details] [review]
Bug 21463: (bug 18789 follow-up) Fix library display on the overdue list view

branchcode is no longer retrieved from the SQL query, we should use the
Koha::Patron object instead.

Test plan:
Create some overdues and list them on Home › Circulation › Overdues
=> With this patch applied you should see that the "Library" column is
correctly filled with the patron's library name
Comment 2 Pierre-Marc Thibault 2018-10-05 20:19:26 UTC
Created attachment 80150 [details] [review]
Bug 21463: (bug 18789 follow-up) Fix library display on the overdue list view

branchcode is no longer retrieved from the SQL query, we should use the
Koha::Patron object instead.

Test plan:
Create some overdues and list them on Home › Circulation › Overdues
=> With this patch applied you should see that the "Library" column is
correctly filled with the patron's library name

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>
Comment 3 Katrin Fischer 2018-10-06 19:31:24 UTC
Created attachment 80166 [details] [review]
Bug 21463: (bug 18789 follow-up) Fix library display on the overdue list view

branchcode is no longer retrieved from the SQL query, we should use the
Koha::Patron object instead.

Test plan:
Create some overdues and list them on Home › Circulation › Overdues
=> With this patch applied you should see that the "Library" column is
correctly filled with the patron's library name

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Nick Clemens 2018-10-09 16:22:36 UTC
Awesome work all!

Pushed to master for 18.11
Comment 5 Martin Renvoize 2018-10-15 10:59:20 UTC
Pushed to 18.05.x for 18.05.05
Comment 6 Fridolin SOMERS 2018-10-24 09:04:50 UTC
Depends on Bug 18789 not in 17.11.x