Bug 21477 - Use of REMOTE_ADDR causes problems when Koha is behind a proxy
Summary: Use of REMOTE_ADDR causes problems when Koha is behind a proxy
Status: RESOLVED DUPLICATE of bug 23068
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-02 17:25 UTC by Nick Clemens
Modified: 2019-06-13 17:21 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2018-10-02 17:25:59 UTC
For sysprefs like: RestrictedPageLocalIP we check the REMOTE_ADDR to get the IP, for setups behind a proxy we have seen issues as the IP is not matching the users IP.

We should have a support for checking X_FORWARDED_FOR in order to check the IP of the end user
Comment 1 Eric Phetteplace 2018-10-15 16:04:26 UTC
I just wanted to chime in that this effects us, as we'd like to offer limited access to media via the Restricted Page feature without forcing a sign-in from on campus but are hosted behind a proxy by ByWater.
Comment 2 Ed Veal 2019-05-28 20:52:48 UTC
I would also like to add that we would be interested in a solution to this issue as well. It is preventing us from providing the best customer service we can as a library. 

Ed
Comment 3 Kyle M Hall 2019-06-13 17:21:52 UTC

*** This bug has been marked as a duplicate of bug 23068 ***