Bug 21553 - Javascript error on rota page
Summary: Javascript error on rota page
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Martin Renvoize
URL:
Whiteboard:
Keywords:
Depends on: 11897
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-11 21:18 UTC by Katrin Fischer
Modified: 2018-10-15 17:20 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 21553: Remove JS error on the Rota view (1.50 KB, patch)
2018-10-12 14:19 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21553: Remove JS error on the Rota view (1.54 KB, patch)
2018-10-12 14:42 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21553: Remove JS error on the Rota view (1.61 KB, patch)
2018-10-12 15:32 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2018-10-11 21:18:28 UTC
Turn on StockRotation system preference

1) Go to a staff detail page
2) Switch to rota page
3) Check web developer tools:

ReferenceError: _ is not defined[Learn More] stockrotation.pl:61:9
<anonymous>
http://localhost:8081/cgi-bin/koha/catalogue/stockrotation.pl:61:9
Comment 1 Jonathan Druart 2018-10-12 14:19:51 UTC
Created attachment 80506 [details] [review]
Bug 21553: Remove JS error on the Rota view

JS error was:
 ReferenceError: _ is not defined

The strings after staff-global.js (for the function _)

Test plan:
Turn on StockRotation system preference

1) Go to a staff detail page
2) Switch to rota page
3) Check web developer tools
Comment 2 Owen Leonard 2018-10-12 14:42:25 UTC
Created attachment 80514 [details] [review]
Bug 21553: Remove JS error on the Rota view

JS error was:
 ReferenceError: _ is not defined

The strings after staff-global.js (for the function _)

Test plan:
Turn on StockRotation system preference

1) Go to a staff detail page
2) Switch to rota page
3) Check web developer tools

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Martin Renvoize 2018-10-12 15:32:56 UTC
Created attachment 80520 [details] [review]
Bug 21553: Remove JS error on the Rota view

JS error was:
 ReferenceError: _ is not defined

The strings after staff-global.js (for the function _)

Test plan:
Turn on StockRotation system preference

1) Go to a staff detail page
2) Switch to rota page
3) Check web developer tools

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 4 Martin Renvoize 2018-10-12 15:33:49 UTC
Ooops.. I think I introduced this one in the first place during a Stock Rotation rebase.. my bad.

Looks good now, thanks for fixing it.

Passing QA
Comment 5 Tomás Cohen Arazi 2018-10-12 18:36:53 UTC
Pushed for 18.11. Thanks all!
Comment 6 Martin Renvoize 2018-10-15 17:19:54 UTC
Caused by bug 11897 not in 18.05.x series.