Bug 21611 - Priority in request.pl shows 1 instead of Waiting
Summary: Priority in request.pl shows 1 instead of Waiting
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
Depends on: 19469
Blocks: 21608 21752
  Show dependency treegraph
 
Reported: 2018-10-18 21:26 UTC by Christopher Brannon
Modified: 2019-10-14 19:58 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21611: Fix priority dropdown for holds (2.18 KB, patch)
2018-10-25 11:33 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 21611: Fix priority dropdown for holds (2.25 KB, patch)
2018-10-26 10:32 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 21611: Fix priority dropdown for holds (2.31 KB, patch)
2018-10-27 23:43 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Brannon 2018-10-18 21:26:08 UTC
To test:
1) Place and item on hold.
2) Trigger the hold.
3) Go to request.pl.  Notice that priority shows "1" rather than "Waiting", even though it shows as waiting in the Pickup library column.
Comment 1 Christopher Brannon 2018-10-18 21:38:47 UTC
As is, bug gives a misleading status, and makes it impossible to set back to priority 1.
Comment 2 Jonathan Druart 2018-10-22 20:47:29 UTC
Caused by bug 19469.
Comment 3 Christopher Brannon 2018-10-24 17:23:21 UTC
(In reply to Jonathan Druart from comment #2)
> Caused by bug 19469.

Confirmed.
Comment 4 Nick Clemens 2018-10-25 11:33:40 UTC
Created attachment 81130 [details] [review]
Bug 21611: Fix priority dropdown for holds

To Test:
 1 - Find a record
 2 - Place several holds some with differing pickup locations
 3 - Check in one hold to confirm as waiting
 4 - Check another in to set a hold in transit
 5 - View the holds queue for the record:
    /cgi-bin/koha/reserve/request.pl?biblionumber=##
 6 - Confirm found holds are incorrect
 7 - Apply patch
 8 - Reload
 9 - Confirm holds look correct
10 - Alter the values of HoldsSplitQueue and HoldsSplitQueueNumbering
11 - Confirm things still look right
Comment 5 Martin Renvoize 2018-10-26 10:32:55 UTC
Created attachment 81271 [details] [review]
Bug 21611: Fix priority dropdown for holds

To Test:
 1 - Find a record
 2 - Place several holds some with differing pickup locations
 3 - Check in one hold to confirm as waiting
 4 - Check another in to set a hold in transit
 5 - View the holds queue for the record:
    /cgi-bin/koha/reserve/request.pl?biblionumber=##
 6 - Confirm found holds are incorrect
 7 - Apply patch
 8 - Reload
 9 - Confirm holds look correct
10 - Alter the values of HoldsSplitQueue and HoldsSplitQueueNumbering
11 - Confirm things still look right

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 6 Martin Renvoize 2018-10-26 10:33:37 UTC
Works as expected, Signing Off
Comment 7 Katrin Fischer 2018-10-27 23:43:15 UTC
Created attachment 81382 [details] [review]
Bug 21611: Fix priority dropdown for holds

To Test:
 1 - Find a record
 2 - Place several holds some with differing pickup locations
 3 - Check in one hold to confirm as waiting
 4 - Check another in to set a hold in transit
 5 - View the holds queue for the record:
    /cgi-bin/koha/reserve/request.pl?biblionumber=##
 6 - Confirm found holds are incorrect
 7 - Apply patch
 8 - Reload
 9 - Confirm holds look correct
10 - Alter the values of HoldsSplitQueue and HoldsSplitQueueNumbering
11 - Confirm things still look right

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Nick Clemens 2018-10-29 01:17:31 UTC
Awesome work all!

Pushed to master for 18.11
Comment 9 Martin Renvoize 2018-11-08 15:27:11 UTC
Cause not in 18.05.x series.