Bug 2169 - Paying only partial fines
Summary: Paying only partial fines
Status: CLOSED DUPLICATE of bug 3498
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: PC All
: P3 enhancement (vote)
Assignee: Kyle M Hall
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-27 05:18 UTC by Nicole C. Engard
Modified: 2012-10-26 00:40 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Fines System Updates - Code Cleanup & Additional Features (19.63 KB, patch)
2010-06-02 12:02 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:47:22 UTC


---- Reported by nengard@gmail.com 2008-05-27 05:18:18 ----

For fines what if you don't want to pay the full amount? You owe $10 you want to pay $5 today.  I know I can do the a credit, but that doesn't apply it to the item number

    * OL: Fines in general need to be gone over with a fine-toothed comb. NPL has never been able to use Koha's fines management because of flakiness like that.



---- Additional Comments From nengard@gmail.com 2009-04-19 18:11:00 ----

Adding Ryan cause he's working on re-writing accounts & fines.



---- Additional Comments From arm@hanover.ca 2009-05-20 23:40:15 ----


Our previous system allowed us to enter the total amount of money paid against fines, and then calculated which fine amounts were fully paid, which left unpaid and which partly paid. 

Example, a borrower with 7 fines of $1 each wants to pay $4.50. The system should pay off the oldest four $1 fines, and .50c off the next oldest, leaving two fines of $1 each and one reduced to .50c. This was a really helpful and time saving behavior, much appreciated by staff.




---- Additional Comments From beckybell@waldolib.org 2009-06-24 03:39:56 ----

When a partial payment is made using a manual credit, it's treated as an unallocated credit that reduces the total amount due but it doesn't mark overdue fines as paid up to the total amount paid. This creates a great deal of confusion for circulation staff. After a manual credit is applied, the total amount is decreased, but the account page still displays the original fine amount as the balance. When a patron is ready to pay the fines, staff will view the account screen and assume that the charges are correct. Even though the balance is shown at the top of the page and is less than the sum of outstanding fines, the staff will assume that the total of all the fines listed is that amount. After all fines are marked paid, there will be an overpayment indicated as a negative balance. 

WALDO library staff would also really appreciate this bug being fixed as soon as possible.



---- Additional Comments From nengard@gmail.com 2009-12-20 21:14:41 ----

I have a suggestion for how to manage this.  I say that on this page: /cgi-bin/koha/members/pay.pl?borrowernumber=51 we change the amount box to an editable text box.  We leave it populated with the full amount of the fine, but allow the librarian to edit the amount if the patron is paying only a part of the fine.  I'm not sure of the database structure and how to track that the fine is partially paid, this is just a suggestion for layout/design.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:47 UTC  ---

This bug was previously known as _bug_ 2169 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2169

Actual time not defined. Setting to 0.0
CC member adrea@moablibrary.org does not have an account here
CC member arm@hanover.ca does not have an account here
CC member bchurch@ptfs.com does not have an account here
CC member beckybell@waldolib.org does not have an account here
CC member melanie@salpublib.org does not have an account here
CC member rch@liblime.com does not have an account here
CC member scook@hartford.edu does not have an account here

Comment 1 Kyle M Hall 2010-06-02 12:02:44 UTC
Created attachment 2193 [details] [review]
Fines System Updates - Code Cleanup & Additional Features

* Major code cleanup for pay.pl
* Added ability to negotiate fines ( i.e. Change the fine amount )
* Added ability to pay, writeoff, and negotiate partial amounts.
* Moved additional functions from pay.pl to Accounts.pm
Comment 2 Owen Leonard 2011-10-13 19:06:04 UTC

*** This bug has been marked as a duplicate of bug 3498 ***