Bug 21758 - Navigation in Z39.50 result pages not working in Acquisitions
Summary: Navigation in Z39.50 result pages not working in Acquisitions
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Owen Leonard
QA Contact: Marcel de Rooy
URL:
Keywords:
Depends on: 20038
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-02 18:26 UTC by Caroline Cyr La Rose
Modified: 2020-01-06 20:17 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
The next page, previous page, and go buttons now work when navigating the search results when adding a record to a basket from an external source.
Version(s) released in:


Attachments
Bug 21758: Navigation in Z39.50 result pages not working in Acquisitions (5.29 KB, patch)
2018-11-21 16:54 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21758: Navigation in Z39.50 result pages not working in Acquisitions (5.34 KB, patch)
2018-11-21 21:02 UTC, David Nind
Details | Diff | Splinter Review
Bug 21758: Navigation in Z39.50 result pages not working in Acquisitions (5.43 KB, patch)
2018-11-23 07:05 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Caroline Cyr La Rose 2018-11-02 18:26:10 UTC
When I try to add a record to a basket from Z39.50, I can't seem to go to the next pages of results. I'm stuck on the first page.

To reproduce:
1) Go to Acquisitions
2) Search for a Vendor (or add a vendor)
3) Create a new basket
4) Click 'Add to basket'
5) Choose 'from external source'
6) Search for a term (I searched for 'cats' in title and the target is Library of Congress)
7) Check the number of results (I get 1 to 20 of 20, which I find suspect, I'm pretty sure LOC has more than 20 titles containing 'cats' in their collection)
8) Check the number of results pages (I have 1 / 286)
9) Click on Next page (nothing happens)
10) Enter a page number in the 'Go to page' box and click 'Go' (I get an error message saying 'Please choose at least one external target')

Can someone test and tell me if they get the same thing?

Thanks!
Comment 1 Katrin Fischer 2018-11-06 07:16:59 UTC
I can confirm - the navigation is broken.
Comment 2 Owen Leonard 2018-11-21 16:13:58 UTC
Caused by Bug 20038.
Comment 3 Owen Leonard 2018-11-21 16:54:56 UTC Comment hidden (obsolete)
Comment 4 David Nind 2018-11-21 21:02:55 UTC Comment hidden (obsolete)
Comment 6 David Nind 2018-11-21 21:50:39 UTC
Noticed that search results displays 'Showing 1 to 20 of 20' at the start and end of every search results page.

Should this display the total number of results and the place in the pagination?

This doesn't affect fixing up the issue in the bug, but would be good to fix up as well if it is easy enough to do.
Comment 7 Marcel de Rooy 2018-11-23 07:05:36 UTC
Created attachment 82587 [details] [review]
Bug 21758: Navigation in Z39.50 result pages not working in Acquisitions

This patch makes markup corrections to the acquisitions Z39.50 search
results template so that the navigation form works correctly.

Also changed: Removed invalid type attributes from style and script
tags.

To test, apply the patch and go to Acquisitions -> Vendor -> Basket.

- Add to basket -> From an external source
- Perform a Z39.50 search which will return multiple pages of results
- On the search results page, use the form at the bottom of the page to
  navigate through results. Confirm that both the "Go" form and the
  next/previous buttons work.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 8 Nick Clemens 2018-11-26 12:55:05 UTC
Awesome work all!

Pushed to master for 18.11
Comment 9 Lucas Gass 2018-12-07 22:34:41 UTC
Doesn't apply cleanly. Please rebase for 18.05.

Thanks