Bug 21928 - CircAutoPrintQuickSlip 'clear' is not working
Summary: CircAutoPrintQuickSlip 'clear' is not working
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 18789
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-30 14:01 UTC by Nick Clemens
Modified: 2019-01-09 06:45 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21928: (bug 18789 follow-up) Fix CircAutoPrintQuickSlip=clear (899 bytes, patch)
2018-12-05 21:18 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21928: (bug 18789 follow-up) Fix CircAutoPrintQuickSlip=clear (943 bytes, patch)
2018-12-17 13:55 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21928: (bug 18789 follow-up) Fix CircAutoPrintQuickSlip=clear (1008 bytes, patch)
2019-01-01 22:10 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2018-11-30 14:01:50 UTC
caused by commit 105b3e10e8b31b7de6d733e676c3e661a39b1280

bug 18789

To recreate:
1 - Set CircAutoPrintQuickSlip to 'clear'
2 - Bring up a patron in circulation
3 - Click in checkout box and hit enter to submit empty
4 - Patron is partially loaded
Comment 1 Jonathan Druart 2018-12-05 21:18:14 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2018-12-17 13:55:51 UTC
Created attachment 83281 [details] [review]
Bug 21928: (bug 18789 follow-up) Fix CircAutoPrintQuickSlip=clear

caused by commit 105b3e10e8b31b7de6d733e676c3e661a39b1280

bug 18789

To recreate:
1 - Set CircAutoPrintQuickSlip to 'clear'
2 - Bring up a patron in circulation
3 - Click in checkout box and hit enter to submit empty
4 - Patron is partially loaded

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Katrin Fischer 2019-01-01 22:10:33 UTC
Created attachment 83566 [details] [review]
Bug 21928: (bug 18789 follow-up) Fix CircAutoPrintQuickSlip=clear

caused by commit 105b3e10e8b31b7de6d733e676c3e661a39b1280

bug 18789

To recreate:
1 - Set CircAutoPrintQuickSlip to 'clear'
2 - Bring up a patron in circulation
3 - Click in checkout box and hit enter to submit empty
4 - Patron is partially loaded

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Nick Clemens 2019-01-02 21:11:08 UTC
Awesome work all!

Pushed to master for 19.05
Comment 5 Martin Renvoize 2019-01-07 15:10:33 UTC
Pushed to 18.11.x for 18.11.02
Comment 6 Lucas Gass 2019-01-08 23:30:51 UTC
backported to 18.05 for 18.05.08
Comment 7 Fridolin SOMERS 2019-01-09 06:45:00 UTC
Depends on Bug 18789 not in 17.11.x