Bug 22076 - SIP checkin for withdrawn item returns ok in checkin response
Summary: SIP checkin for withdrawn item returns ok in checkin response
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: SIP2 (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Martin Renvoize
URL:
Keywords:
: 21745 (view as bug list)
Depends on: 22043
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-07 17:45 UTC by Kyle M Hall
Modified: 2019-04-01 11:05 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 22076 - SIP checkin for withdrawn item returns ok in checkin response (2.59 KB, patch)
2019-01-07 17:49 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 22076 - SIP checkin for withdrawn item returns ok in checkin response (2.64 KB, patch)
2019-01-08 11:17 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 22076 - SIP checkin for withdrawn item returns ok in checkin response (2.71 KB, patch)
2019-01-09 12:03 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 22076 - Fix the same situation for lost items (1.04 KB, patch)
2019-01-09 12:03 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 22076 - Add missing whitespace on if statments (2.07 KB, patch)
2019-01-09 12:06 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 22076: SIP checkin for withdrawn item returns ok in checkin response (2.70 KB, patch)
2019-03-26 07:17 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 22076: Fix the same situation for lost items (1.09 KB, patch)
2019-03-26 07:17 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 22076: Add missing whitespace on if statments (2.18 KB, patch)
2019-03-26 07:17 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 22076: SIP checkin for withdrawn item returns ok in checkin response (2.76 KB, patch)
2019-03-26 07:19 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 22076: Fix the same situation for lost items (1.15 KB, patch)
2019-03-26 07:19 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 22076: Add missing whitespace on if statments (2.18 KB, patch)
2019-03-26 07:19 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2019-01-07 17:45:23 UTC
If an item that is withdrawn is checked in via SIP2, Koha does not process the checkin, but still indicates the checkin succeeded via the ok flag in the checkin response message.
Comment 1 Kyle M Hall 2019-01-07 17:49:30 UTC
Created attachment 83694 [details] [review]
Bug 22076 - SIP checkin for withdrawn item returns ok in checkin response

If an item that is withdrawn is checked in via SIP2, Koha does not process the checkin, but still indicates the checkin succeeded via the ok flag in the checkin response message.

To recreate:
 1 - Mark an item withdrawn
 2 - Set up sip server:
     https://wiki.koha-community.org/wiki/Koha_SIP2_server_setup
 3 - Set 'BlockReturnOfWithdrawnItems' to block
 4 - Use the sip_cli_emulator to checkin the withdrawn item
 5 - There is no error in the checkin

Test Plan:
1) Mark an item withdrawn
2) Set BlockReturnOfWithdrawnItems to block
3) Use the sip cli emulator to checkin the withdrawn item
4) Note the response begins with 101
5) Apply this patch
6) Restart all the things ( including SIP server )
7) Repeat checkin with sip cli emulator
8) Note the checkin now beings with 100
Comment 2 Kyle M Hall 2019-01-07 17:50:01 UTC
*** Bug 21745 has been marked as a duplicate of this bug. ***
Comment 3 Nick Clemens 2019-01-08 11:17:29 UTC
Created attachment 83709 [details] [review]
Bug 22076 - SIP checkin for withdrawn item returns ok in checkin response

If an item that is withdrawn is checked in via SIP2, Koha does not process the checkin, but still indicates the checkin succeeded via the ok flag in the checkin response message.

To recreate:
 1 - Mark an item withdrawn
 2 - Set up sip server:
     https://wiki.koha-community.org/wiki/Koha_SIP2_server_setup
 3 - Set 'BlockReturnOfWithdrawnItems' to block
 4 - Use the sip_cli_emulator to checkin the withdrawn item
 5 - There is no error in the checkin

Test Plan:
1) Mark an item withdrawn
2) Set BlockReturnOfWithdrawnItems to block
3) Use the sip cli emulator to checkin the withdrawn item
4) Note the response begins with 101
5) Apply this patch
6) Restart all the things ( including SIP server )
7) Repeat checkin with sip cli emulator
8) Note the checkin now beings with 100

Signed-off-by: Geeta Halley <ghalley@roundrocktexas.gov>
Comment 4 Kyle M Hall 2019-01-09 12:03:47 UTC
Created attachment 83737 [details] [review]
Bug 22076 - SIP checkin for withdrawn item returns ok in checkin response

If an item that is withdrawn is checked in via SIP2, Koha does not process the checkin, but still indicates the checkin succeeded via the ok flag in the checkin response message.

To recreate:
 1 - Mark an item withdrawn
 2 - Set up sip server:
     https://wiki.koha-community.org/wiki/Koha_SIP2_server_setup
 3 - Set 'BlockReturnOfWithdrawnItems' to block
 4 - Use the sip_cli_emulator to checkin the withdrawn item
 5 - There is no error in the checkin

Test Plan:
1) Mark an item withdrawn
2) Set BlockReturnOfWithdrawnItems to block
3) Use the sip cli emulator to checkin the withdrawn item
4) Note the response begins with 101
5) Apply this patch
6) Restart all the things ( including SIP server )
7) Repeat checkin with sip cli emulator
8) Note the checkin now beings with 100

Signed-off-by: Geeta Halley <ghalley@roundrocktexas.gov>
Comment 5 Kyle M Hall 2019-01-09 12:03:55 UTC
Created attachment 83738 [details] [review]
Bug 22076 - Fix the same situation for lost items

Signed-off-by: Geeta Halley <ghalley@roundrocktexas.gov>
Comment 6 Kyle M Hall 2019-01-09 12:06:42 UTC
Created attachment 83739 [details] [review]
Bug 22076 - Add missing whitespace on if statments
Comment 7 Marcel de Rooy 2019-02-15 09:26:49 UTC
        * Commit title does not start with 'Bug XXXXX: ' - 8ab6da3438
        * Commit title does not start with 'Bug XXXXX: ' - f1d99e01d1
        * Commit title does not start with 'Bug XXXXX: ' - e79dbc7dbc

Please adjust yourself now. This is required for a longer time already ;)
Comment 8 Martin Renvoize 2019-03-26 07:17:46 UTC
Created attachment 87000 [details] [review]
Bug 22076: SIP checkin for withdrawn item returns ok in checkin response

If an item that is withdrawn is checked in via SIP2, Koha does not process the checkin, but still indicates the checkin succeeded via the ok flag in the checkin response message.

To recreate:
 1 - Mark an item withdrawn
 2 - Set up sip server:
     https://wiki.koha-community.org/wiki/Koha_SIP2_server_setup
 3 - Set 'BlockReturnOfWithdrawnItems' to block
 4 - Use the sip_cli_emulator to checkin the withdrawn item
 5 - There is no error in the checkin

Test Plan:
1) Mark an item withdrawn
2) Set BlockReturnOfWithdrawnItems to block
3) Use the sip cli emulator to checkin the withdrawn item
4) Note the response begins with 101
5) Apply this patch
6) Restart all the things ( including SIP server )
7) Repeat checkin with sip cli emulator
8) Note the checkin now beings with 100

Signed-off-by: Geeta Halley <ghalley@roundrocktexas.gov>
Rescued-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 9 Martin Renvoize 2019-03-26 07:17:50 UTC
Created attachment 87001 [details] [review]
Bug 22076: Fix the same situation for lost items

Signed-off-by: Geeta Halley <ghalley@roundrocktexas.gov>
Rescued-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 10 Martin Renvoize 2019-03-26 07:17:53 UTC
Created attachment 87002 [details] [review]
Bug 22076: Add missing whitespace on if statments

Rescued-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 11 Martin Renvoize 2019-03-26 07:19:19 UTC
Created attachment 87003 [details] [review]
Bug 22076: SIP checkin for withdrawn item returns ok in checkin response

If an item that is withdrawn is checked in via SIP2, Koha does not process the checkin, but still indicates the checkin succeeded via the ok flag in the checkin response message.

To recreate:
 1 - Mark an item withdrawn
 2 - Set up sip server:
     https://wiki.koha-community.org/wiki/Koha_SIP2_server_setup
 3 - Set 'BlockReturnOfWithdrawnItems' to block
 4 - Use the sip_cli_emulator to checkin the withdrawn item
 5 - There is no error in the checkin

Test Plan:
1) Mark an item withdrawn
2) Set BlockReturnOfWithdrawnItems to block
3) Use the sip cli emulator to checkin the withdrawn item
4) Note the response begins with 101
5) Apply this patch
6) Restart all the things ( including SIP server )
7) Repeat checkin with sip cli emulator
8) Note the checkin now beings with 100

Signed-off-by: Geeta Halley <ghalley@roundrocktexas.gov>
Rescued-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 12 Martin Renvoize 2019-03-26 07:19:23 UTC
Created attachment 87004 [details] [review]
Bug 22076: Fix the same situation for lost items

Signed-off-by: Geeta Halley <ghalley@roundrocktexas.gov>
Rescued-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 13 Martin Renvoize 2019-03-26 07:19:26 UTC
Created attachment 87005 [details] [review]
Bug 22076: Add missing whitespace on if statments

Rescued-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 14 Martin Renvoize 2019-03-26 07:20:22 UTC
Patches rescued and QA run done.. Passing QA
Comment 15 Nick Clemens 2019-03-28 13:28:53 UTC
Awesome work all!

Pushed to master for 19.05
Comment 16 Martin Renvoize 2019-04-01 11:05:54 UTC
Bug with enhancement not in 18.11.x series.