Bug 22083 - Typo in circulation_batch_checkouts.tt
Summary: Typo in circulation_batch_checkouts.tt
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Caroline Cyr La Rose
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-08 14:24 UTC by Caroline Cyr La Rose
Modified: 2019-02-25 09:39 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 22083: Typo in circulation_batch_checkouts.tt (2.24 KB, patch)
2019-01-08 14:32 UTC, Caroline Cyr La Rose
Details | Diff | Splinter Review
Bug 22083: Typo in circulation_batch_checkouts.tt (2.30 KB, patch)
2019-01-09 19:15 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22083: Typo in circulation_batch_checkouts.tt (2.37 KB, patch)
2019-01-13 17:34 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Caroline Cyr La Rose 2019-01-08 14:24:08 UTC
There is a typo in circulation_batch_checkouts.tt that makes Koha skip a warning if the user cannot borrow due to circulation rules.

To reproduce:
1. In Administration > Global system preferences, 'Allow' BatchCheckouts and enter patron categories in BatchCheckoutsValidCategories
2. Go to Administration > Circulation and fines rules
3. Enter a rule where a certain category of patrons (that is in BatchCheckoutsValidCategories) cannot take out a particular item type
4. Search the catalog for an item of that item type
5. Copy the barcode
6. Go into patrons and find a patron of that category
7. Click on the Batch checkout tab
8. Paste the barcode in the box and click Check out
9. It should say 'Too many checked out'

It should also say 'This patron can't check out this item per library circulation policy'.
Comment 1 Caroline Cyr La Rose 2019-01-08 14:32:48 UTC
Created attachment 83715 [details] [review]
Bug 22083: Typo in circulation_batch_checkouts.tt

There is a typo in circulation_batch_checkouts.tt that makes Koha skip a warning if the user cannot borrow due to circulation rules.

This patch corrects this typo.

To test:

1. In Administration > Global system preferences, 'Allow' BatchCheckouts and enter patron categories in BatchCheckoutsValidCategories
2. Go to Administration > Circulation and fines rules
3. Enter a rule where a certain category of patrons (that is in BatchCheckoutsValidCategories) cannot take out a particular item type
4. Search the catalog for an item of that item type
5. Copy the barcode
6. Go into patrons and find a patron of that category
7. Click on the Batch checkout tab
8. Paste the barcode in the box and click Check out
9. It should say 'Too many checked out'
10. Apply the patch
11. Try the check out again, it should show both warnings ('Too many checked out' and 'This patron can't check out this item per library circulation policy')
Comment 2 Caroline Cyr La Rose 2019-01-08 14:43:46 UTC
I also think that the 'too many checked out' warning should only appear if the circulation rules allow 1 or more. If the circulation rules allow 0, only 'This patron can't check out this item per library circulation rules' should show...

It is, however, outside of the scope of this bug and outside my capabilities... Just throwing it out there if someone wants to take it over :)
Comment 3 Owen Leonard 2019-01-09 19:15:20 UTC
Created attachment 83763 [details] [review]
Bug 22083: Typo in circulation_batch_checkouts.tt

There is a typo in circulation_batch_checkouts.tt that makes Koha skip
a warning if the user cannot borrow due to circulation rules.

This patch corrects this typo.

To test:

1. In Administration > Global system preferences, 'Allow'
   BatchCheckouts and enter patron categories in
   BatchCheckoutsValidCategories
2. Go to Administration > Circulation and fines rules
3. Enter a rule where a certain category of patrons (that is in
   BatchCheckoutsValidCategories) cannot take out a particular item type
4. Search the catalog for an item of that item type
5. Copy the barcode
6. Go into patrons and find a patron of that category
7. Click on the Batch checkout tab
8. Paste the barcode in the box and click Check out
9. It should say 'Too many checked out'
10. Apply the patch
11. Try the check out again, it should show both warnings ('Too many
    checked out' and 'This patron can't check out this item per library
    circulation policy')

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 4 Katrin Fischer 2019-01-13 17:34:43 UTC
Created attachment 83842 [details] [review]
Bug 22083: Typo in circulation_batch_checkouts.tt

There is a typo in circulation_batch_checkouts.tt that makes Koha skip
a warning if the user cannot borrow due to circulation rules.

This patch corrects this typo.

To test:

1. In Administration > Global system preferences, 'Allow'
   BatchCheckouts and enter patron categories in
   BatchCheckoutsValidCategories
2. Go to Administration > Circulation and fines rules
3. Enter a rule where a certain category of patrons (that is in
   BatchCheckoutsValidCategories) cannot take out a particular item type
4. Search the catalog for an item of that item type
5. Copy the barcode
6. Go into patrons and find a patron of that category
7. Click on the Batch checkout tab
8. Paste the barcode in the box and click Check out
9. It should say 'Too many checked out'
10. Apply the patch
11. Try the check out again, it should show both warnings ('Too many
    checked out' and 'This patron can't check out this item per library
    circulation policy')

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Katrin Fischer 2019-01-13 17:35:01 UTC
Thx, Caroline!
Comment 6 Nick Clemens 2019-01-28 14:16:35 UTC
Awesome work all!

Pushed to master for 19.05
Comment 7 Martin Renvoize 2019-02-01 12:38:33 UTC
Pushed to 18.11.x for 18.11.03
Comment 8 Jesse Maseto 2019-02-06 18:05:58 UTC
Pushed to 18.05.x for 18.05.09
Comment 9 Fridolin SOMERS 2019-02-12 15:24:52 UTC
Pushed to 17.11.x for 17.11.15