Bug 22136 - Import patrons notes hides a note because the syspref isn't referenced correctly
Summary: Import patrons notes hides a note because the syspref isn't referenced correctly
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low minor (vote)
Assignee: Ethan
QA Contact: Testopia
URL:
Keywords: Academy
Depends on: 12598
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-15 23:07 UTC by Aleisha Amohia
Modified: 2019-02-12 15:44 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 22136: Added 'ExtendedPatronAttributes' notes to 'Import Patrons' notes. (1.99 KB, patch)
2019-01-16 04:04 UTC, Ethan
Details | Diff | Splinter Review
Bug 22136: Added 'ExtendedPatronAttributes' notes to 'Import Patrons' notes. (1.58 KB, patch)
2019-01-17 20:15 UTC, Ethan
Details | Diff | Splinter Review
Bug 22136: Added 'ExtendedPatronAttributes' notes to 'Import Patrons' notes. (1.65 KB, patch)
2019-01-18 19:54 UTC, Pierre-Marc Thibault
Details | Diff | Splinter Review
Bug 22136: Added 'ExtendedPatronAttributes' notes to 'Import Patrons' notes. (1.71 KB, patch)
2019-01-20 11:55 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2019-01-15 23:07:00 UTC
To reproduce:

Go to Tools -> Import patrons
Look under Notes
There should be NO note talking about the patron_attributes field.
Go to Administration -> system preferences
Enable the ExtendedPatronAttributes syspref
Go back to Tools -> Import patrons
Notice the note still hasn't shown up, but it is meant to.

This is because it is not checking the system preference correctly
The code says [% IF ( ExtendedPatronAttributes ) %]
but it should say [% IF ( Koha.Preference('ExtendedPatronAttributes') ) %]
Comment 1 Ethan 2019-01-16 04:04:19 UTC
Created attachment 84042 [details] [review]
Bug 22136: Added 'ExtendedPatronAttributes' notes to 'Import Patrons' notes.
Comment 2 Katrin Fischer 2019-01-17 06:51:03 UTC
Hi Ethan, please take another look here, I tihnk something has gone wrong:

-                [% IF ( Koha.Preference('ExtendedPatronAttributes') == 1 ) %]
+                [% IF ( Koha.Preference(''tronAttributes) == 1 ) %]
Comment 3 Ethan 2019-01-17 20:15:51 UTC
Created attachment 84156 [details] [review]
Bug 22136: Added 'ExtendedPatronAttributes' notes to 'Import Patrons' notes.

Fixed ExtendedPatronAttributes typo.
Comment 4 Pierre-Marc Thibault 2019-01-18 19:54:10 UTC
Created attachment 84217 [details] [review]
Bug 22136: Added 'ExtendedPatronAttributes' notes to 'Import Patrons' notes.

Fixed ExtendedPatronAttributes typo.

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>
Comment 5 Katrin Fischer 2019-01-20 11:55:15 UTC
Created attachment 84242 [details] [review]
Bug 22136: Added 'ExtendedPatronAttributes' notes to 'Import Patrons' notes.

Fixed ExtendedPatronAttributes typo.

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Nick Clemens 2019-01-28 16:14:09 UTC
Awesome work all!

Pushed to master for 19.05
Comment 7 Martin Renvoize 2019-02-01 14:52:11 UTC
Pushed to 18.11.x for 18.11.03
Comment 8 Jesse Maseto 2019-02-06 18:06:35 UTC
Pushed to 18.05.x for 18.05.09
Comment 9 Fridolin SOMERS 2019-02-12 15:44:00 UTC
Depends on Bug 12598 not in 17.11.x