Bug 22360 - On order information missing in OPAC normal display
Summary: On order information missing in OPAC normal display
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 21205
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-17 21:06 UTC by Iming Chan
Modified: 2019-03-26 06:27 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
OPACacquisitiondetail (182.73 KB, image/png)
2019-02-18 04:08 UTC, Iming Chan
Details
Acquisition detail for the biblio. record for library staff. (174.29 KB, image/png)
2019-02-18 04:10 UTC, Iming Chan
Details
Biblio. with "On Order" detail missing (174.29 KB, image/png)
2019-02-18 04:11 UTC, Iming Chan
Details
Bug 22360: (bug 21205 follow-up) Restore OPACAcquisitionDetails behavior (1.29 KB, patch)
2019-02-21 18:30 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 22360: (bug 21205 follow-up) Restore OPACAcquisitionDetails behavior (1.34 KB, patch)
2019-02-27 20:39 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 22360: (bug 21205 follow-up) Restore OPACAcquisitionDetails behavior (1.40 KB, patch)
2019-02-28 06:39 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Iming Chan 2019-02-17 21:06:44 UTC
On order information is missing when there is an order linked to the bibliographic record.

The order is showing under "Acquisitions" tab in the staff catalogue record correctly.
Comment 1 Katrin Fischer 2019-02-17 21:08:38 UTC
Hi Irmin, can you give us some more information?

- Where did you choose to create items on creating the basket?
- Where are you missing the information (which page? acquisition module or somewhere else?)
Comment 2 Katrin Fischer 2019-02-17 21:09:38 UTC
Is OPACAcquisitionDetails active?
Comment 3 Iming Chan 2019-02-18 04:06:47 UTC
(In reply to Katrin Fischer from comment #1)
> Hi Irmin, can you give us some more information?
> 
> - Where did you choose to create items on creating the basket?

We haven't created the item until it is received from the supplier.

> - Where are you missing the information (which page? acquisition module or
> somewhere else?)

The missing information is at the bottom of OPAC page.  I have supplied and attached additional screen images.
Comment 4 Iming Chan 2019-02-18 04:08:53 UTC
Created attachment 85230 [details]
OPACacquisitiondetail
Comment 5 Iming Chan 2019-02-18 04:10:42 UTC
Created attachment 85231 [details]
Acquisition detail for the biblio. record for library staff.
Comment 6 Iming Chan 2019-02-18 04:11:28 UTC
Created attachment 85232 [details]
Biblio. with "On Order" detail missing
Comment 7 Iming Chan 2019-02-18 04:13:03 UTC
We are running Koha 18.11.02.
Comment 8 Jonathan Druart 2019-02-21 18:17:41 UTC
(In reply to Iming Chan from comment #6)
> Created attachment 85232 [details]
> Biblio. with "On Order" detail missing

This image is the same one as the other. You uploaded twice the same image.
Comment 9 Jonathan Druart 2019-02-21 18:27:35 UTC
I do recreate, "X items are on order." is missing at the OPAC.
Caused by
  commit 7d10549ae8632e6640d3a99014268a2a1e46b3c4
  Bug 21205: Replace C4::Items::GetOrderFromItemnumber calls
Comment 10 Jonathan Druart 2019-02-21 18:30:50 UTC
Created attachment 85474 [details] [review]
Bug 22360: (bug 21205 follow-up) Restore OPACAcquisitionDetails behavior

Caused by
  commit 7d10549ae8632e6640d3a99014268a2a1e46b3c4
  Bug 21205: Replace C4::Items::GetOrderFromItemnumber calls

At this point $order is a Koha::Acquisition::Order object, not a hashref
anymore.

Test plan:
Create an order, receive items
Enable OPACAcquisitionDetails
At the detail page of the bibliographic record you should see
"X items are on order." at the bottom of the items list
Comment 11 Josef Moravec 2019-02-27 20:39:54 UTC
Created attachment 85798 [details] [review]
Bug 22360: (bug 21205 follow-up) Restore OPACAcquisitionDetails behavior

Caused by
  commit 7d10549ae8632e6640d3a99014268a2a1e46b3c4
  Bug 21205: Replace C4::Items::GetOrderFromItemnumber calls

At this point $order is a Koha::Acquisition::Order object, not a hashref
anymore.

Test plan:
Create an order, receive items
Enable OPACAcquisitionDetails
At the detail page of the bibliographic record you should see
"X items are on order." at the bottom of the items list

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 12 Katrin Fischer 2019-02-28 06:39:36 UTC
Created attachment 85803 [details] [review]
Bug 22360: (bug 21205 follow-up) Restore OPACAcquisitionDetails behavior

Caused by
  commit 7d10549ae8632e6640d3a99014268a2a1e46b3c4
  Bug 21205: Replace C4::Items::GetOrderFromItemnumber calls

At this point $order is a Koha::Acquisition::Order object, not a hashref
anymore.

Test plan:
Create an order, receive items
Enable OPACAcquisitionDetails
At the detail page of the bibliographic record you should see
"X items are on order." at the bottom of the items list

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 13 Nick Clemens 2019-03-04 18:49:30 UTC
Awesome work all!

Pushed to master for 19.05
Comment 14 Martin Renvoize 2019-03-05 14:44:16 UTC
Pushed to 18.11.x for 18.11.04
Comment 15 Lucas Gass 2019-03-11 22:16:22 UTC
missing dependency for 18.05.x. not backporting
Comment 16 Fridolin SOMERS 2019-03-26 06:27:48 UTC
Depends on Bug 21205 not in 17.11.x