Bug 22419 - Removing multiple records from intranet cart causes browser timeout
Summary: Removing multiple records from intranet cart causes browser timeout
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 19290
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-26 17:36 UTC by Lucas Gass
Modified: 2019-05-27 12:34 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
timeout_screenshot (108.97 KB, image/png)
2019-02-26 17:36 UTC, Lucas Gass
Details
Bug 22419: Records listed twice when select/unselect all from the cart (1.37 KB, patch)
2019-03-05 18:23 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 22419: Records listed twice when select/unselect all from the cart (1.42 KB, patch)
2019-03-05 19:04 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 22419: Records listed twice when select/unselect all from the cart (1.48 KB, patch)
2019-03-06 07:22 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Gass 2019-02-26 17:36:11 UTC
Created attachment 85724 [details]
timeout_screenshot

Removing multiple items from basket.pl on the staff client causes the browser to timeout. (see attached) I can recreate this in both Firefox and Chrome.
Comment 1 Jonathan Druart 2019-03-05 18:15:01 UTC
Caused by
  commit c9a7b6742b970d1e605f84ff001f609ddda8eaa2
  Bug 19290: Browse selected bibliographic records - Staff interface
Comment 2 Jonathan Druart 2019-03-05 18:23:46 UTC
Created attachment 86110 [details] [review]
Bug 22419: Records listed twice when select/unselect all from the cart

It fixes a browser timeout when records are removed from the cart.
The onchange event already call selRecord.

Test plan:
Launch a search
Add all the result to your cart
Open the cart
Click "select all"
Then remove them all from your cart
=> Without this patch the action will timeout
=> With this patch applied the action is immediate
Comment 3 Lucas Gass 2019-03-05 19:04:05 UTC
Created attachment 86113 [details] [review]
Bug 22419: Records listed twice when select/unselect all from the cart

It fixes a browser timeout when records are removed from the cart.
The onchange event already call selRecord.

Test plan:
Launch a search
Add all the result to your cart
Open the cart
Click "select all"
Then remove them all from your cart
=> Without this patch the action will timeout
=> With this patch applied the action is immediate

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Comment 4 Katrin Fischer 2019-03-05 21:09:00 UTC
Hi Lucas, please change the status to 'signed off' when you sign-off :)
Comment 5 Katrin Fischer 2019-03-06 07:22:51 UTC
Created attachment 86129 [details] [review]
Bug 22419: Records listed twice when select/unselect all from the cart

It fixes a browser timeout when records are removed from the cart.
The onchange event already call selRecord.

Test plan:
Launch a search
Add all the result to your cart
Open the cart
Click "select all"
Then remove them all from your cart
=> Without this patch the action will timeout
=> With this patch applied the action is immediate

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Nick Clemens 2019-03-07 21:22:18 UTC
Awesome work all!

Pushed to master for 19.05
Comment 7 Martin Renvoize 2019-03-12 08:44:47 UTC
Pushed to 18.11.x for 18.11.04
Comment 8 Lucas Gass 2019-03-15 17:09:57 UTC
backported to 18.05.x for 18.05.11