Bug 22442 - Item search CSV export broken
Summary: Item search CSV export broken
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 13618
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-01 13:27 UTC by Owen Leonard
Modified: 2019-05-27 12:34 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 22442: (bug 13618 follow-up) Fix item search CSV export (1.74 KB, patch)
2019-03-04 17:53 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 22442: (bug 13618 follow-up) Fix item search CSV export (1.79 KB, patch)
2019-03-04 19:04 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 22442: (bug 13618 follow-up) Fix item search CSV export (1.85 KB, patch)
2019-03-08 07:09 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2019-03-01 13:27:39 UTC
Several columns in the item search CSV export are empty: Title, Publication date, Publisher, Collection.

I think this was caused by the template variable filter switch.
Comment 1 Jonathan Druart 2019-03-04 17:53:03 UTC
Created attachment 86021 [details] [review]
Bug 22442: (bug 13618 follow-up) Fix item search CSV export

We must not filter assignements statements.

Test plan:
Export item search result as CSV
Without this patch the biblio and biblioitem values are not displayed.
With this patch applied everything is displayed correctly
Comment 2 Josef Moravec 2019-03-04 19:04:46 UTC
Created attachment 86026 [details] [review]
Bug 22442: (bug 13618 follow-up) Fix item search CSV export

We must not filter assignements statements.

Test plan:
Export item search result as CSV
Without this patch the biblio and biblioitem values are not displayed.
With this patch applied everything is displayed correctly

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 3 Katrin Fischer 2019-03-08 07:09:42 UTC
Created attachment 86337 [details] [review]
Bug 22442: (bug 13618 follow-up) Fix item search CSV export

We must not filter assignements statements.

Test plan:
Export item search result as CSV
Without this patch the biblio and biblioitem values are not displayed.
With this patch applied everything is displayed correctly

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Nick Clemens 2019-03-11 13:13:52 UTC
Awesome work all!

Pushed to master for 19.05
Comment 5 Martin Renvoize 2019-03-12 08:50:18 UTC
Pushed to 18.11.x for 18.11.04
Comment 6 Lucas Gass 2019-03-15 17:26:46 UTC
not backporting to 18.05.x