Bug 22580 - Remove deprecated delete_expired_opac_registrations.pl cronjob
Summary: Remove deprecated delete_expired_opac_registrations.pl cronjob
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Command-line Utilities (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Katrin Fischer
QA Contact: Testopia
URL:
Keywords: Academy, release-notes-needed
: 22465 (view as bug list)
Depends on: 22465
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-26 09:36 UTC by Martin Renvoize
Modified: 2019-06-27 09:24 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
The functionality of delete_expired_opac_registrations.pl was moved into the cleanup_database.pl cronjob. Please make sure to adjust your conjob configuration accordingly.
Version(s) released in:
19.05.00


Attachments
Bug 22580: Remove deprecated delete_expired_opac_registrations.pl cronjob (4.25 KB, patch)
2019-04-09 23:18 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 22580: Remove deprecated delete_expired_opac_registrations.pl cronjob (4.31 KB, patch)
2019-04-10 15:26 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 22680: OPAC language footer not positioned correctly (2.28 KB, patch)
2019-04-10 18:10 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Renvoize 2019-03-26 09:36:25 UTC
misc/cronjobs/delete_expired_opac_registrations.pl states within it that the script is deprecated in favour of using clean_database.pl with a flag.

The deprecation message was added back in October 2014.. I think sufficient time has passed such that we can remove this script now ;)
Comment 1 Katrin Fischer 2019-04-09 23:08:23 UTC
*** Bug 22465 has been marked as a duplicate of this bug. ***
Comment 2 Katrin Fischer 2019-04-09 23:18:08 UTC
Created attachment 87690 [details] [review]
Bug 22580: Remove deprecated delete_expired_opac_registrations.pl cronjob

Removes the deprecated script and changes the hint on the
PatronSelfRegistrationExpireTemporaryAccountsDelay sytem preference.

To test:
- Make sure the script misc/cronjobs/delete_expired_opac_registrations.pl
  was deleted
- Make sure the hint on the PatronSelfRegistrationExpireTemporaryAccountsDelay
  system preference is correct
- Make sure there are no other reference to the removed script
Comment 3 Katrin Fischer 2019-04-09 23:18:48 UTC
As we remove the other related script in this release, it would make sense to remove this one in 19.05 as well.
Comment 4 Martin Renvoize 2019-04-10 15:26:45 UTC
Created attachment 87726 [details] [review]
Bug 22580: Remove deprecated delete_expired_opac_registrations.pl cronjob

Removes the deprecated script and changes the hint on the
PatronSelfRegistrationExpireTemporaryAccountsDelay sytem preference.

To test:
- Make sure the script misc/cronjobs/delete_expired_opac_registrations.pl
  was deleted
- Make sure the hint on the PatronSelfRegistrationExpireTemporaryAccountsDelay
  system preference is correct
- Make sure there are no other reference to the removed script

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 5 Martin Renvoize 2019-04-10 15:27:11 UTC
+1

Signing off
Comment 6 Martin Renvoize 2019-04-10 15:28:40 UTC
Going to go straight for a PQA on this one.. no references found anywhere and it's a simple removal.
Comment 7 Owen Leonard 2019-04-10 18:10:04 UTC Comment hidden (obsolete)
Comment 8 Nick Clemens 2019-04-17 12:29:06 UTC
Awesome work all!

Pushed to master for 19.05
Comment 9 Martin Renvoize 2019-04-26 13:23:16 UTC
Enhancement will not be backported to 18.11.x series.