Bug 22621 - Filters on subscription result list search the wrong column
Summary: Filters on subscription result list search the wrong column
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 18426
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-02 09:40 UTC by Séverine Queune
Modified: 2019-10-14 20:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.05.00, 18.11.05


Attachments
Sceenshot 1 - search failed (34.92 KB, image/png)
2019-04-02 09:40 UTC, Séverine Queune
Details
Sceenshot 1 - search succeed using the fliter of the column on the right (41.24 KB, image/png)
2019-04-02 09:41 UTC, Séverine Queune
Details
Bug 22621: Fix filters on subscription search results (3.25 KB, patch)
2019-04-24 02:53 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 22621: Fix filters on subscription search results (3.30 KB, patch)
2019-04-25 09:16 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 22621: Fix filters on subscription search results (3.37 KB, patch)
2019-04-25 12:15 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Séverine Queune 2019-04-02 09:40:04 UTC
Created attachment 87315 [details]
Sceenshot 1 - search failed

On the serial subscription page result, the filters search the column on its left. Could it be the first column with check box but without filter that create the gap ?

See the 2 screenshots attached :
  - #1 : failed searching "notes" using the filter on "Notes" column
  - #2 : 1 result (as expected) searching "notes" using the filter on "Library" column
Comment 1 Séverine Queune 2019-04-02 09:41:19 UTC
Created attachment 87316 [details]
Sceenshot 1 - search succeed using the fliter of the column on the right
Comment 2 Jonathan Druart 2019-04-24 02:53:12 UTC
Created attachment 88585 [details] [review]
Bug 22621: Fix filters on subscription search results

Caused by
  commit 4e698f7b478a094d7b32ebfeaa917bca05ebcc5b
  Bug 18426: Allow to edit subscriptions in batch

There is a shift caused by a hidden column, which make the filters
searching on the previous column.

Test plan:
- Add 1+ searchable additional field for subscription
- Create a new subscription
- Search for subscriptions
- Use the column filters to filter the results
=> The results must be filtered accordingly
Comment 3 Claire Gravely 2019-04-25 09:16:45 UTC
Created attachment 88730 [details] [review]
Bug 22621: Fix filters on subscription search results

Caused by
  commit 4e698f7b478a094d7b32ebfeaa917bca05ebcc5b
  Bug 18426: Allow to edit subscriptions in batch

There is a shift caused by a hidden column, which make the filters
searching on the previous column.

Test plan:
- Add 1+ searchable additional field for subscription
- Create a new subscription
- Search for subscriptions
- Use the column filters to filter the results
=> The results must be filtered accordingly

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>
Comment 4 Kyle M Hall 2019-04-25 12:15:15 UTC
Created attachment 88773 [details] [review]
Bug 22621: Fix filters on subscription search results

Caused by
  commit 4e698f7b478a094d7b32ebfeaa917bca05ebcc5b
  Bug 18426: Allow to edit subscriptions in batch

There is a shift caused by a hidden column, which make the filters
searching on the previous column.

Test plan:
- Add 1+ searchable additional field for subscription
- Create a new subscription
- Search for subscriptions
- Use the column filters to filter the results
=> The results must be filtered accordingly

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 5 Nick Clemens 2019-04-26 12:41:38 UTC
Awesome work all!

Pushed to master for 19.05
Comment 6 Martin Renvoize 2019-04-26 15:56:09 UTC
Pushed to 18.11.x for 18.11.05
Comment 7 Lucas Gass 2019-05-24 17:31:14 UTC
backported to 18.05.x for 18.05.13