Bug 22664 - Link basket name and basket group name instead of the, often short, basket numbers
Summary: Link basket name and basket group name instead of the, often short, basket nu...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Liz Rea
QA Contact: Martin Renvoize
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-08 18:48 UTC by Katrin Fischer
Modified: 2019-05-18 10:09 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
This enhancement moves the basket link from the basket number to the basket name aiding usability and improving consistency.
Version(s) released in:
19.05.00


Attachments
Bug 22664: Link names in order search results instead of numbers (2.03 KB, patch)
2019-04-08 19:06 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 22664: Link names in order search results instead of numbers (2.02 KB, patch)
2019-04-08 19:10 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 22664: Link names in order search results instead of numbers (2.08 KB, patch)
2019-04-08 19:13 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 22664: Link names in order search results instead of numbers (2.14 KB, patch)
2019-04-17 10:03 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 22664: More making acquisitions links more easily clickable (4.28 KB, patch)
2019-04-18 01:16 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 22664: Link names in order search results instead of numbers (2.28 KB, patch)
2019-04-18 12:11 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 22664: More making acquisitions links more easily clickable (4.48 KB, patch)
2019-04-18 12:11 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 22664: Link names in order search results instead of numbers (2.29 KB, patch)
2019-04-25 06:15 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 22664: More making acquisitions links more easily clickable (4.54 KB, patch)
2019-04-25 06:15 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2019-04-08 18:48:51 UTC
Currently the link is only on the number, that can be hard to see and hard to click. I propose to link the name as well.

Example:
Basket name (1)
Comment 1 Liz Rea 2019-04-08 19:06:13 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2019-04-08 19:10:56 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2019-04-08 19:13:31 UTC Comment hidden (obsolete)
Comment 4 Martin Renvoize 2019-04-17 10:03:15 UTC Comment hidden (obsolete)
Comment 5 Martin Renvoize 2019-04-17 10:03:40 UTC
Nice improvement, Passing QA
Comment 6 Martin Renvoize 2019-04-17 10:04:09 UTC
I do however wonder.. are there other places we should make such a change too to be consistent for UX
Comment 7 Katrin Fischer 2019-04-17 10:11:24 UTC
I plan on doing some more, if noone beats me to it. Already noticed the issue is also on the receive page.
Comment 8 Liz Rea 2019-04-17 23:59:27 UTC
let's do a bunch for 10 years. :)
Comment 9 Liz Rea 2019-04-18 01:16:23 UTC Comment hidden (obsolete)
Comment 10 sandboxes@biblibre.com 2019-04-18 12:11:10 UTC
Patch tested with a sandbox, by Séverine QUEUNE <severine.queune@bulac.fr>
Comment 11 sandboxes@biblibre.com 2019-04-18 12:11:39 UTC Comment hidden (obsolete)
Comment 12 sandboxes@biblibre.com 2019-04-18 12:11:42 UTC Comment hidden (obsolete)
Comment 13 Séverine Queune 2019-04-18 12:12:53 UTC
(In reply to Liz Rea from comment #9)
> Created attachment 88246 [details] [review] [review]
> Bug 22664: More making acquisitions links more easily clickable
> 
> To test:
> 
> * create a basket with an order from a staged record, and an order from
> a suggestion
> * add that basket to a basket group when you close it.
> * note that the links to the basket in the first column, the link to the
> basket group in the second column, and the link to
> the suggester in the summary column are very small (only the ID# is
> linked)
> * apply this patch, restart the things
> * refresh the page, note that the previously ogled links are now bigger
> and easier to find and click, and that the links work and such
> * rejoice.

Looked ok, thanks Liz !
Comment 14 Katrin Fischer 2019-04-25 06:15:23 UTC
Created attachment 88684 [details] [review]
Bug 22664: Link names in order search results instead of numbers

To test:
Make up some orders, put some in basket groups.
Search for your vendor's orders, note that the only thing linking to the
order is a tiny number in parentheses.
Apply this patch, restart the things.
Refresh the results, note that te basket names *and* numbers are linked
now.
Rejoice.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>
Comment 15 Katrin Fischer 2019-04-25 06:15:26 UTC
Created attachment 88685 [details] [review]
Bug 22664: More making acquisitions links more easily clickable

To test:

* create a basket with an order from a staged record, and an order from
a suggestion
* add that basket to a basket group when you close it.
* note that the links to the basket in the first column, the link to the
basket group in the second column, and the link to
the suggester in the summary column are very small (only the ID# is
linked)
* apply this patch, restart the things
* refresh the page, note that the previously ogled links are now bigger
and easier to find and click, and that the links work and such
* rejoice.

Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>
Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 16 Nick Clemens 2019-04-25 11:57:57 UTC
Awesome work all!

Pushed to master for 19.05
Comment 17 Martin Renvoize 2019-04-26 15:30:59 UTC
Enhancement will not be backported to 18.11.x series.