Bug 22762 - Collection codes not displayed on receiving
Summary: Collection codes not displayed on receiving
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 22669
  Show dependency treegraph
 
Reported: 2019-04-24 04:00 UTC by Jonathan Druart
Modified: 2019-10-14 20:02 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.05.00, 18.11.05


Attachments
Bug 22762: Fix items.collection display on receiving (3.09 KB, patch)
2019-04-24 04:07 UTC, Jonathan Druart
Details | Diff | Splinter Review
[<=18.11.x version] Bug 22762: Fix items.collection display on receiving (3.04 KB, patch)
2019-04-24 04:11 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 22762: Fix items.collection display on receiving (3.13 KB, patch)
2019-04-25 10:29 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 22762: Fix items.collection display on receiving (3.21 KB, patch)
2019-04-25 11:47 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2019-04-24 04:00:16 UTC
Caused by
  commit 31c29fd31f557306233e6a2936148a5bb10b89a1
  Bug 21206: Replace C4::Items::GetItem

The log says: The method Koha::Item->collection is not covered by tests!

It has highlighted an older problem:
Since
  commit bb1e9c500c810402c64436c53bcc00ffb9a0b857
  Bug 17248 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValueLib
the "Collection code" is not filled correctly (items.collection vs items.ccode).
Comment 1 Jonathan Druart 2019-04-24 04:07:01 UTC
Created attachment 88587 [details] [review]
Bug 22762: Fix items.collection display on receiving

Caused by
  commit 31c29fd31f557306233e6a2936148a5bb10b89a1
  Bug 21206: Replace C4::Items::GetItem

The log says: The method Koha::Item->collection is not covered by tests!

It has highlighted an older problem:
Since
  commit bb1e9c500c810402c64436c53bcc00ffb9a0b857
  Bug 17248 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValueLib
the "Collection code" is not filled correctly (items.collection vs items.ccode).

Test plan:
- Set acqcreateitem to "when placing an order"
- Receive an order with items
=> The "Collection code" column must be filled with the items.ccode value
- Edit an item (You may need the patches on bug 22669)
- Change the collection code value
=> The "Collection code" column must be filled with the new value
Comment 2 Jonathan Druart 2019-04-24 04:11:06 UTC
Created attachment 88588 [details] [review]
[<=18.11.x version] Bug 22762: Fix items.collection display on receiving

Caused by
  commit 31c29fd31f557306233e6a2936148a5bb10b89a1
  Bug 21206: Replace C4::Items::GetItem

The log says: The method Koha::Item->collection is not covered by tests!

It has highlighted an older problem:
Since
  commit bb1e9c500c810402c64436c53bcc00ffb9a0b857
  Bug 17248 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValueLib
the "Collection code" is not filled correctly (items.collection vs items.ccode).

Test plan:
- Set acqcreateitem to "when placing an order"
- Receive an order with items
=> The "Collection code" column must be filled with the items.ccode value
- Edit an item
- Change the collection code value
=> The "Collection code" column must be filled with the new value
Comment 3 Claire Gravely 2019-04-25 09:23:13 UTC
Hiya, sorry I got following conflict when applying this

Auto-merging catalogue/getitem-ajax.pl
CONFLICT (content): Merge conflict in catalogue/getitem-ajax.pl
Failed to merge in the changes.
Patch failed at 0001 Bug 22762: Fix items.collection display on receiving
Comment 4 Claire Gravely 2019-04-25 10:02:15 UTC
(In reply to Claire Gravely from comment #3)
> Hiya, sorry I got following conflict when applying this
> 
> Auto-merging catalogue/getitem-ajax.pl
> CONFLICT (content): Merge conflict in catalogue/getitem-ajax.pl
> Failed to merge in the changes.
> Patch failed at 0001 Bug 22762: Fix items.collection display on receiving

sorry, just saw the second patch is for other versions. First applies just fine!
Comment 5 Claire Gravely 2019-04-25 10:29:11 UTC
Created attachment 88747 [details] [review]
Bug 22762: Fix items.collection display on receiving

Caused by
  commit 31c29fd31f557306233e6a2936148a5bb10b89a1
  Bug 21206: Replace C4::Items::GetItem

The log says: The method Koha::Item->collection is not covered by tests!

It has highlighted an older problem:
Since
  commit bb1e9c500c810402c64436c53bcc00ffb9a0b857
  Bug 17248 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValueLib
the "Collection code" is not filled correctly (items.collection vs items.ccode).

Test plan:
- Set acqcreateitem to "when placing an order"
- Receive an order with items
=> The "Collection code" column must be filled with the items.ccode value
- Edit an item (You may need the patches on bug 22669)
- Change the collection code value
=> The "Collection code" column must be filled with the new value

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>
Comment 6 Claire Gravely 2019-04-25 10:32:44 UTC
note: I have NOT tested the second patch for earlier versions.
Comment 7 Kyle M Hall 2019-04-25 11:47:49 UTC
Created attachment 88757 [details] [review]
Bug 22762: Fix items.collection display on receiving

Caused by
  commit 31c29fd31f557306233e6a2936148a5bb10b89a1
  Bug 21206: Replace C4::Items::GetItem

The log says: The method Koha::Item->collection is not covered by tests!

It has highlighted an older problem:
Since
  commit bb1e9c500c810402c64436c53bcc00ffb9a0b857
  Bug 17248 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValueLib
the "Collection code" is not filled correctly (items.collection vs items.ccode).

Test plan:
- Set acqcreateitem to "when placing an order"
- Receive an order with items
=> The "Collection code" column must be filled with the items.ccode value
- Edit an item (You may need the patches on bug 22669)
- Change the collection code value
=> The "Collection code" column must be filled with the new value

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 8 Nick Clemens 2019-04-25 12:02:57 UTC
Awesome work all!

Pushed to master for 19.05
Comment 9 Martin Renvoize 2019-04-26 15:04:16 UTC
18.11 version pushed to 18.11.x for 18.11.05.

Thanks Jonathan.
Comment 10 Lucas Gass 2019-05-16 01:18:18 UTC
backported to 18.05.x for 18.05.13