Bug 22903 - Elasticsearch, dynamic display when you refine your search
Summary: Elasticsearch, dynamic display when you refine your search
Status: RESOLVED DUPLICATE of bug 14419
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: axel Amghar
QA Contact:
URL:
Keywords:
Depends on: 22924
Blocks:
  Show dependency treegraph
 
Reported: 2019-05-14 12:36 UTC by axel Amghar
Modified: 2019-09-05 09:14 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 22903 - Elasticsearch, dynamic display when you refine your search (7.98 KB, patch)
2019-05-16 09:16 UTC, axel Amghar
Details | Diff | Splinter Review
Bug 22903: Elasticsearch, dynamic display when you refine your search (7.98 KB, patch)
2019-05-16 09:19 UTC, axel Amghar
Details | Diff | Splinter Review
Bug 22903: Elasticsearch, dynamic display when you refine your search (9.73 KB, patch)
2019-05-16 11:30 UTC, axel Amghar
Details | Diff | Splinter Review
Bug 22903: Elasticsearch, dynamic display when you refine your search (10.19 KB, patch)
2019-05-16 14:34 UTC, axel Amghar
Details | Diff | Splinter Review
Bug 22903: Unit test for sub getRecords in C4/Search.pm (28.52 KB, patch)
2019-05-17 07:42 UTC, axel Amghar
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description axel Amghar 2019-05-14 12:36:36 UTC
With elastic search when you use characters like é, à, ç ... the first reasearch show up correctly but when you refine your search with "Show more", the encoding becomes bad and so, results of the reasearch too.
Comment 1 axel Amghar 2019-05-15 11:50:14 UTC
The solution could be to show dynamically the results when you click on "Show more".
Comment 2 axel Amghar 2019-05-16 09:16:29 UTC Comment hidden (obsolete)
Comment 3 axel Amghar 2019-05-16 09:19:24 UTC Comment hidden (obsolete)
Comment 4 axel Amghar 2019-05-16 11:30:14 UTC Comment hidden (obsolete)
Comment 5 axel Amghar 2019-05-16 14:34:05 UTC
Created attachment 89850 [details] [review]
Bug 22903: Elasticsearch, dynamic display when you refine your search

To test:

With Elasticsearch->
Without the patch:
- check if you have your SysPref SearchEngine with Elasticsearch as value,
- put your SysPref FacetMaxCount at 10,
- search in the catalog "a" and then in Refine your search click on show more (just to see how it works),
- then search with special characters like "é", ç" ... and make the same test, the research should be wrong when you click on show more and the page is realoaded.

Then apply the patch:
- and make the same with a classic reasearch, then with special characters,
- verify that when you click on show more the page isn't realoded and the reasearch is correct.
- same with show less
- and finnaly, add some facets and test show more/less

With Zerbra ->
- put your SysPref SearchEngine with Zebra as value,
- and make the same thing as elasticsearch
Comment 6 axel Amghar 2019-05-17 07:42:56 UTC
Created attachment 89880 [details] [review]
Bug 22903: Unit test for sub getRecords in C4/Search.pm
Comment 7 Nick Clemens 2019-07-05 20:26:24 UTC

*** This bug has been marked as a duplicate of bug 14419 ***