Bug 2318 - Attempting to view details of a biblio that does not exists results in a 404 error
Summary: Attempting to view details of a biblio that does not exists results in a 404 ...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-08 08:46 UTC by Chris Nighswonger
Modified: 2012-10-25 23:03 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:49:48 UTC


---- Reported by cnighswonger@foundations.edu 2008-07-08 08:46:09 ----

Try

http://biblios.campus.foundations.edu:8080/cgi-bin/koha/catalogue/detail.pl?biblionumber=(some number that does not exist)

This should probably provide a more informative error message to the effect that this biblio does not exist.



---- Additional Comments From cnighswonger@foundations.edu 2008-07-08 08:58:34 ----

that previous url does not work and should be constructed as follows:

cgi-bin/koha/catalogue/detail.pl?biblionumber=(some number that does not exist)




---- Additional Comments From cnighswonger@foundations.edu 2008-07-08 09:30:58 ----

404 error is by design



---- Additional Comments From mjr@ttllp.co.uk 2008-07-08 11:00:08 ----

Even so, the 404 should contain a more informative message than "page not found".  "Item not found" perhaps?




---- Additional Comments From oleonard@myacpl.org 2008-07-08 11:12:05 ----

Chris N. and I talked about this some in #koha. The issue stems from whether you consider detail.pl to be the "page," which loads individual records, or whether you consider detail.pl?biblionumber=X to be the page, and detail.pl?biblionumber=Y is another page, and so on. While I find it counter-intuitive, an argument can be made that the "average" user is more likely to think the latter. See Amazon.com and Worldcat.org for other examples of the 404 behavior.



---- Additional Comments From mjr@ttllp.co.uk 2008-07-08 15:29:26 ----

I'm not arguing against the 404 behaviour.  I'm suggesting that the 404 message should be more accurate and not refer to "page" the same as if you put a random address into koha.  This confuses librarians IME.




---- Additional Comments From oleonard@myacpl.org 2008-07-08 16:17:01 ----

Since the 404 behavior uses the standard method for displaying errors, I wonder what would be involved in customizing the error? A re-thinking of how errors are displayed, at the very least, which probably makes this a 3.2 bug.



---- Additional Comments From jmf@liblime.com 2008-07-14 09:40:41 ----

I agree, this is a rel_3_2 bug :-)



---- Additional Comments From mjr@ttllp.co.uk 2008-07-15 05:06:51 ----

"what would be involved in customizing the error?"

Adding a parameter to the Location generated by detail.pl and making 404.pl react properly to that parameter.  No general rethinking required AFAICS.

What should the message say?  Is "item not found" OK or is there a word that would avoid the item/biblio confusion?




---- Additional Comments From chris.nighswonger@liblime.com 2008-07-15 14:07:01 ----

I have found that Koha throws 404 errors in situations which are really just like the one mentioned in this bug rather than simply in situations where the page truly does not exist. As MJ suggests, I would like to see a bit more informative error when the 404 is given such as "This item no longer exists." At the very least, something needs to show up in koha-error_log or koha-opac-error_log as appropriate since the 404 is a bit deceiving to an admin attempting to figure out exactly what cause the 404 to trip. Especially in light of the fact that most pages that throw a 404 do, in fact, exist.

I concur that this is a rel_3_2 issue, however.



---- Additional Comments From nengard@gmail.com 2009-12-23 17:59:15 ----

This bug hasn't been touched in nearly a year, please revisit and test and close if appropriate.



---- Additional Comments From cnighswonger@foundations.edu 2009-12-23 18:23:17 ----

Changing this to an enhancement request. I'm not sure this will make it into 3.2, but should probably be considered as an item for the cleanup work proposed for 3.4.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:49 UTC  ---

This bug was previously known as _bug_ 2318 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2318

Actual time not defined. Setting to 0.0
CC member mjr@ttllp.co.uk does not have an account here

Comment 1 Tomás Cohen Arazi 2011-04-08 19:19:23 UTC
What needs to be done with this bug? I solved smth similar for staff interface.
Comment 2 Katrin Fischer 2011-05-14 09:42:18 UTC
The example URL from this bug provides a nice error message in 3.4:

The record you requested does not exist ((some number that does not exist)).

Can this bug be closed?
Do we need a similar handling of non existing biblionumbers for OPAC?
Comment 3 Chris Nighswonger 2011-05-14 19:49:23 UTC
(In reply to comment #2)
> The example URL from this bug provides a nice error message in 3.4:
> 
> The record you requested does not exist ((some number that does not exist)).
> 
> Can this bug be closed?

Yes.. doing that now.

> Do we need a similar handling of non existing biblionumbers for OPAC?

Yes, but under a new bug report, perhaps.