Bug 23222 - Fix DISABLE/ENABLE plugin label in plugins home
Summary: Fix DISABLE/ENABLE plugin label in plugins home
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Plugin architecture (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Agustín Moyano
QA Contact: Testopia
URL:
Keywords:
: 23300 (view as bug list)
Depends on: 21073
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-26 19:14 UTC by Agustín Moyano
Modified: 2019-11-14 11:43 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.11.00


Attachments
Bug 23222: Update plugins-home.tt with new ENABLE/DISABLE flag name (2.93 KB, patch)
2019-06-28 17:08 UTC, Agustín Moyano
Details | Diff | Splinter Review
Bug 23222: Update plugins-home.tt with new ENABLE/DISABLE flag name (3.06 KB, patch)
2019-06-29 07:13 UTC, Frédéric Demians
Details | Diff | Splinter Review
Bug 23222: Update plugins-home.tt with new ENABLE/DISABLE flag name (3.12 KB, patch)
2019-07-01 20:00 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Agustín Moyano 2019-06-26 19:14:56 UTC
Fix bug introduced in bug 21073

When you install a plugin, it shows as disables, even though it's enabled in database.

Before 21073 that flag was called "enabled", after that bug it is called "is_enabled", but tt was never updated.
Comment 1 Agustín Moyano 2019-06-28 17:08:15 UTC
Created attachment 91111 [details] [review]
Bug 23222: Update plugins-home.tt with new ENABLE/DISABLE flag name

At some point of history, the flag to indicate if a plugin was enabled/disabled was called "enabled", now it's called "is_enabled"

To test:
1) get a fresh master copy
2) Enable plugins
3) Install any plugin
CHECK => plugin appears as disabled
      => If you try to enable it, it just appears as disabled just the same
4) Apply this patch
5) Reload page
SUCCESS => plugin appears as enabled
        => enable / disable action works again
6) Sign off
Comment 2 Frédéric Demians 2019-06-29 07:13:34 UTC
Created attachment 91129 [details] [review]
Bug 23222: Update plugins-home.tt with new ENABLE/DISABLE flag name

At some point of history, the flag to indicate if a plugin was enabled/disabled was called "enabled", now it's called "is_enabled"

To test:
1) get a fresh master copy
2) Enable plugins
3) Install any plugin
CHECK => plugin appears as disabled
      => If you try to enable it, it just appears as disabled just the same
4) Apply this patch
5) Reload page
SUCCESS => plugin appears as enabled
        => enable / disable action works again
6) Sign off

Signed-off-by: Frédéric Demians <f.demians@tamil.fr>
Comment 3 Tomás Cohen Arazi 2019-07-01 20:00:12 UTC
Created attachment 91163 [details] [review]
Bug 23222: Update plugins-home.tt with new ENABLE/DISABLE flag name

At some point of history, the flag to indicate if a plugin was enabled/disabled was called "enabled", now it's called "is_enabled"

To test:
1) get a fresh master copy
2) Enable plugins
3) Install any plugin
CHECK => plugin appears as disabled
      => If you try to enable it, it just appears as disabled just the same
4) Apply this patch
5) Reload page
SUCCESS => plugin appears as enabled
        => enable / disable action works again
6) Sign off

Signed-off-by: Frédéric Demians <f.demians@tamil.fr>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 4 Martin Renvoize 2019-07-02 08:22:55 UTC
Nice work, thanks!!

Pushed to master to 19.11.00
Comment 5 Andrew Isherwood 2019-07-15 09:12:13 UTC
*** Bug 23300 has been marked as a duplicate of this bug. ***